7 Replies Latest reply on Jul 1, 2013 10:30 AM by sundown

    Loosing pdf file in Remote Email

    sundown

      Title

      Loosing pdf file in Remote Email

      Post

           I have the pdf emails working good from my iMac where I am Hosting the FMP file. But when I perform the email from remote, only the first email (from the list of email addresses) has the pdf attachment. I thought it was solved when i used the functions Phil sent me, but I was only testing it with a single email. The multiple email addresses works from host.

           I am attaching a snapshot of my script . Hopefully Phil can point out my error.

            

            

      Script.jpg

        • 1. Re: Loosing pdf file in Remote Email
          sundown

               Correction! I was trying to email to 3 addresses. It is the LAST email address that has the pdf attachment, not the first two.

               When i set the first Variable where I set the $PDFPath, does it matter what I name the pdf?

          • 2. Re: Loosing pdf file in Remote Email
            philmodjunk

                 Might this be from an iPhone or iPad client?

            • 3. Re: Loosing pdf file in Remote Email
              sundown

                   No, I am emailing them to my own .mac mail account while I am testing this.  Here is my test

                   I selected 3 client records which I merge their status into a form letter. Each record has the clients email address in a field. I have entered my email address in all 3 while I am testing this email script.

                   Whether i select 3 or more records to email, it work great on my iMac that is hosting the file. When I use my MacBook Air to go to the Remote file, I select the same 3 records & send out the 3 emails (one for each record but all emailed to me), 3 emails are sent, but only the last has a pdf attachment.

                    

              • 4. Re: Loosing pdf file in Remote Email
                sundown

                     Could this be a timing response on Remote that looses the first pdf files in the $PDFpath variable? I don't understand the path variable setup in Remote well enought to see the limitation.

                Is there another way to do this like first creating all pdf files & identifying or attaching them to the corresponding record, & then make another loop that emails them?

                • 5. Re: Loosing pdf file in Remote Email
                  sundown

                       Phil, i have put a pause in the send-email loop and it works.

                       Just prior to the Go-To-Next-record in the loop in my attachment, I added a Pause/Resume delay, first of 10 secs, then 1 sec, then 0.5 seconds then 0.1 secs., and the Remote email pdf attachment worked in all cases.

                       It must be a delay in the $PDFPath when in Remote that is causing the loss of the attachment.

                       Would appreciate your input.

                  • 6. Re: Loosing pdf file in Remote Email
                    philmodjunk

                         I don't think that has anything to do with the $path variable. That should not require any pause at all. But if you are emailing via SMTP, a pause is often needed between sending emails and that might be a factor here.

                         To learn more about $path variables, you might take a look at this thread: Exploring the use of a $Path Variable in Scripts

                    • 7. Re: Loosing pdf file in Remote Email
                      sundown

                           Thanks for the response Phil.  No, I am sending from my computers local .mac email. Not certain , but I think I tested the remote function earlier with multiple emails on an old iBook using FMP 8.5 & the attachments worked. Did not try repeating this. After i installed a FMP 10 on my MacBook Air, i then tested it & that is when I found that the attachment was only on the last email I had sent. I experimented with the pause time in the email loop, & it works with 0.1 seconds pause, but not without a pause. I just put a 0.3 pause in each of my email scripts & have had no more problems. 

                           Only thing I could assume was that the speed of the new MB Air was faster than the remote $path variable function could respond. I am still curious about the cause, but the pause is no problem & it works. Thanks again for helping me get this email function working. You pointed out some functions I had no idea about.

                           Bob