10 Replies Latest reply on May 11, 2013 7:51 AM by kmsitall

    Lost communication with remote host

    kmsitall

      Title

      Lost communication with remote host

      Post

           FMPro 11 on Mac OS 7 and 8.

           I have a host machine with a set of related databases and use 1 or 2 other macs on a local network to do data entry. The remote macs always use "open remote" to get into the files. These files were originally created about 10 years ago using FMP6 and have migrated and expanded into their current form in FMP 11.

           Recently we have had increasing problems with the remote users suddenly getting a Lost Communication error and they are forced to quit FMP and start a new session.

           We have un-installed and re-installed FMP 11 on all machines.

           The files have been run through a Recover procedure.

           We tested the network by going completely wireless and got the same problems.

           We then tested by pinging the network and found no loss of data.

           We moved the databases to a different desktop and began serving it from there -- with the same Loss of Communication error!!!

           Any ideas?

           Kathleen

        • 1. Re: Lost communication with remote host
          philmodjunk
               

                    The remote macs always use "open remote" to get into the files.

               All your computers--whether outside the network or on the local area network should only use Open Remote to access the file. That may be what you are doing, but if not, any one trying to open the file directly from a shared folder could damage your file.

               If the local area 'wired' users are not having trouble with the database while remote and WiFi users are getting disconnected, it would seem that there is some "glitch" in your network that is disconnecting users.

          • 2. Re: Lost communication with remote host
            kmsitall

                 Thanks PhilModJunk.

                 To clarify, all users are in the same room. Those not on the host machine always use Open Remote.

                 Our network is wired -- we have tried both wired and wireless and both give the same results.

                 K

            • 3. Re: Lost communication with remote host
              GuyStevens

                   I have seen a mac laptop (one of the newer ones) that always lost it's connection after going in "sleep" or "standby" mode.

                   Everytime that happened connection was lost. Solution: connect the laptop to a power supply and make sure it doesn't go to sleep.

                   The moment it goes in stanby the internet connection is lost and the filemaker file needs to be reopened.

                   I don't know if this is something you could look into.

              • 4. Re: Lost communication with remote host
                kmsitall

                     Thanks for the suggestion DaSaint.

                     Both the host and the primary data entry macs are solid newish desktops. It is possible this may be part of the problem for the laptop we use -- but that one is used *very* infrequently and is not our main concern. We will watch out though, that it's not an issue of it sitting idle before losing the connection.

                     Kathleen

                • 5. Re: Lost communication with remote host
                  philmodjunk

                       This will not be easy to isolate.

                       Problems with your database, such as a damaged file can cause this and while Recover almost always finds and fixes damage to a file, there have been been cases where it has failed to fix problems with a damaged file and even when it has failed to detect the file as damaged.

                       But problems with your network can also cause this.

                       As can problems with the host computer or its network interface.

                       If you were using FileMaker Server, I'd ask you to check the log to see what is recorded at the time a user get's disconnected and I'd also suggest that you check and see if the user's privilege set is set to disconnect users when idle. I don't know if that same setting applies when hosting from FileMaker Pro or not.

                  • 6. Re: Lost communication with remote host
                    kmsitall

                         No, unfortunately we're not using Server so I can't use either of those tools. And since we switched the computer that is hosting the files, it shouldn't be the computer's network interface....

                         It's definitely puzzling.

                         K

                    • 7. Re: Lost communication with remote host
                      philmodjunk

                           Which still leaves several other possibilities listed in my previous post...

                      • 8. Re: Lost communication with remote host
                        JimMac

                             You must always use Open Remote....

                             

                        To clarify, all users are in the same room. Those not on the host machine always use Open Remote.

                             You can access the DB on the HOST computer also, but even that one must use Open Remote....

                             If you use the DB directly on the HOST, which may appear already open on you screen when you start the HOST, you can bump everyone off, plus affect Globals, calculations, and if you are not carefull, leave your DB security wide open.

                             If that is not what is happening......

                             I have had same problem.  It was infrequent, but frustrating to someone going for coffee and returning to find a disconnect.angry

                             I finally had a Network expert check out our LAN that has 40 ethernet prewired, 4 remotes switches, one Time Capsule extended Wireless, and AirPort Extreme 1Gbit Wirless router.  Guess what we found, and very very infrequent?

                        Data Collisionssurprise

                        The reason was MacOS, and possibly Windows, has both Wireless and Ethernets ports.  You can set the Preference Order in Network settings.  MacOS will pick the fastest and can do multitasking using both ports cocurrently.  You can also use each MacOS to host other wireless and bluetooth devises toocool

                             Good for flexibilty, but every once in a while.....Data Collisionssurprise

                        Our solution...

                             1) HOST used only Eithernet port for speed, AirPort turned off.

                             2) Clients picked one they preferred and turned the other port off.  Ethernet is fastest speed.

                             3) Encourage your Clients to "Relase Records" when taking a break.  I tell them to return to a Central Navigational Menu Layout that has ZERO fields that can be entered.  Thus, minimal data transmissions on the LAN.

                             Jim...

                        • 9. Re: Lost communication with remote host
                          JimMac

                               One last fact....

                               When our HOST had both Ethernet and AirPort active, they were assigned a different dynamic LAN IP address.  Example:

                               Ethernet  192.168.1.89

                               AirPort  192.168.1. 74

                               You could Favorite Host each of those IP individually and Access the HOST db....coolcrying

                               The Clients could use either... Get the Point?

                               Jim...

                          • 10. Re: Lost communication with remote host
                            kmsitall

                                 Thanks Jim for all your suggestions!

                                 I am about to go over and work and will see what we can do... 

                                 I will be sure that those working on the host are doing so via remote -- I'm not sure that they have been diligent about that, and maybe that's the source of the whole problem.

                                 I'll also have our network person look at your comments and see what she can do with that.

                                 I appreciate your helpful comments very much!  

                                 Kathleen