5 Replies Latest reply on Jul 27, 2012 1:18 PM by monkeymissile

    lost management access to a database

    monkeymissile

      Title

      lost management access to a database

      Post

      Greetings,

      while working on one of my databases I evidently reconfigured the privilege sets and now appear to have just read-only access to it. I had an admin account for management and a universal data-entry-only account for my users.

      Now the manage tab is grayed out and I'm stuck in Browse mode.

      Any idea how I can get back in?

      thanks!

        • 1. Re: lost management access to a database
          MarcMcCall

          Unless you created a runtime solution and removed the admin access, it is my understanding that you have to have at least on account with full access.  A dialog window should pop up when modifying the [Full Access] account to read only and not allow it.  I would verify you are logging in with the correct credentials.

          • 2. Re: lost management access to a database
            monkeymissile

            Hi Marc,

            thanks for the speedy reply. I don't get a login window for this database and I don't get that dialog window either. The database is hosted on our server via FMP Server (v9) and I can access/open it just fine with FMP on my Mac. If I go under Preferences within FMP, under the General tab it shows the User Name as that of the admin account I created, but there's no place to enter a password. So I assume I'm logged in as the admin, but like I said I can't manage anything.

            I have tried closing/re-opening FMP to no avail. Opening the database from other workstations gives the same result.

            I wish I could remember what I did.....

            • 3. Re: lost management access to a database
              MarcMcCall

              I'm not to familaiar with files on a a server, all of the projects I have made, or worked on have only been hosted by a standard pc and accessed remotely through the open remote.  I know I have made a few projects that I set up to automatically login by eneterint the credentials in the file oprions tab under File.  Then if I want to open with the Full access acount I hold the shift button, or I think options for mac, then double cklick to open and the password dialog box opens, to allow me to enter another accounts credentials.  I pesonally also have a password recovery program I have had to use for projects I have left on the back burner, and lost all info for and was able to get back in.

              • 4. Re: lost management access to a database
                philmodjunk

                Hold down the shift (Windows) or Option (mac) key while opening the database. You should then see the standard password log in appear.

                Then go to file options and modify the settings there that are automatically entering a password for you to open the database.

                • 5. Re: lost management access to a database
                  monkeymissile

                  Brilliant, thank you both. That did it!

                  Have a great weekend, I know I will now.....