2 Replies Latest reply on Mar 6, 2012 12:39 PM by HankBrice

    Make all the text in a field look identical

    HankBrice

      Title

      Make all the text in a field look identical

      Post

      I have a couple hundred records with data copied in from another application.

      The data in the field in Filemaker retains the font and font size they had in the other application.

      When I go to Layout and set the font and size, it only works on the data I've manually typed into Filemaker.  All the data that were copied in go unchanged and retain their original font and size.

      Does anyone know how to make all the data in that field which were pasted in from another app respond to the Filemaker Format/Size.. or Format/Font...command in Layout?  Do I not do this in Layout mode?

      Thanks much in advance.

        • 1. Re: Make all the text in a field look identical
          philmodjunk

          Do you want to make this change permanent for every where in your database or do you just want to suppress the formattiong for a specific report or layout?

          From your original post, I'd guess that you want a permanent change.

          Use Replace field contents to strip out the formatting with this expression:

          TextFormatRemove ( yourfieldHere )

          First make a back up copy of your database as this will change every record in your table and can't be undone.

          Then select show all records.

          Then click/tab into this text field and choose Replace Field Contents from the Records menu and specify the "calculation" option.

          For future records, you might want to add this auto-enter calculation to the field so that pasting formatted text into the field has the formatting automatically stripped out:

          TextFormatRemove ( Self )

          and clear the "do not replace existing value..." check box.

          • 2. Re: Make all the text in a field look identical
            HankBrice

            Wow, that worked perfectly.  I never would have figured that out in a million years.

             

            Thanks!!!