2 Replies Latest reply on Jul 24, 2013 9:24 AM by jchowchow

    Making a field NOT round

    jchowchow

      Title

      Making a field NOT round

      Post

           I am using Filemaker Pro 12's  Expenses Report template, and I made a global field that always contains the number .505 as the rate per mile.  However, in browse mode it has rounded to .51.  How do I stop filemaker from rounding my numbers?  

        • 1. Re: Making a field NOT round
          philmodjunk

               No such rounding should take place unless someone specifically took steps to make this happen.

               Do you see 0.505 if you click or tab into that field?

               If so: They shouldn't display as rounded values unless you used the Data formatting on the Inspector's data tab to specify a fixed number of decimal places (2 in this case).

               If not: Look for either a an auto-enter caculation that rounds the value in the field or a script trigger that is performing a script that rounds the value.

          • 2. Re: Making a field NOT round
            jchowchow

                 Yes, you were right!  When I clicked into the field, .505 showed up.  I went into layout and looked at data formatting and sure enough it was preset to fixed number of decimals with a 2 entered in next to it.  Templates! - the nerve!   I'm guessing this means I have to go through every layout and change the settings.  

                 Thank you!