1 Reply Latest reply on Feb 4, 2013 8:03 AM by schamblee

    Maps Not working correctly

    Mike_1

      Title

      Maps Not working correctly

      Post

           What am I doing wrong with maps?  I am getting no display at all. I did have a map display of a google search but it wasnt the road map. It was just a pic of the location like I just did a google search. Now I am getting nothing.

            

           This is in the container field..

           "http://maps.google.com/maps?" & "q=" & /*Address=*/ aztecaccounts::ADDRESS & "," & /*City=*/ aztecaccounts::CITY & "," & /*State=*/ aztecaccounts::STATE & "," & /*Zip Code=*/ "" & "," & /*Country=*/ ""

      Capture.JPG

        • 1. Re: Maps Not working correctly
          schamblee

               There are starter solution with examples.  FM 12 contacts has a sample.

               The url in the sample which uses a custom GetMap function

               GetMap ( "Map1" ; 14 ; Contacts::Work Address 1 ; Contacts::Work Address 2 ; Contacts::Work City ; Contacts::Work State ; Contacts::Work Postal Code ; Contacts::Work Country )

                

               GetMap function :

               Let  (
                [
                address =  Substitute  (
                      address1 & " " &
                      address2 & " " &
                      city & " " &
                      state & " " &
                      postalCode & " " &
                      country ;
                      " " ; "+"
                      ) ;
                size =   GetLayoutObjectAttribute ( webViewerName ; "width" ) & "x" & GetLayoutObjectAttribute ( webViewerName ; "height" )
                ] ;

                "http://maps.google.com/maps/api/staticmap?center="
                  & address &
                   "&zoom=" & zoom &
                    "&markers="
                     & address &
                      "&size="
                       & size &
                        "&sensor=false"
                )