AnsweredAssumed Answered

Maximum number of characters issue - sort of

Question asked by indyj on Aug 17, 2014
Latest reply on Aug 17, 2014 by indyj

Title

Maximum number of characters issue - sort of

Post

     Hi all,

     I would appreciate the help with a problem that stumped me. I have a layout (1) with a series of fields with drop-down lists, where a single digit is stored in the database (the dropdown shows two fields, but stores only the numerical code 1-8). I have an additional layout (2) with calculation fields based on the contents of the numerical fields on the first layout. 

     However, whenever a field is changed on layout 1 (say the drop-down choice is changed from 2 to 6), Filemaker for some reason adds spaces in the field after the numerical code, which will not go away even if i try to delete the contents. The spaces are visible if I add the fields in table view on a new layout, where they can be deleted, but they do not show in the drop-down fields on the original layout, not can they be deleted there. I need to be able to keep the fields on layout 1 to the one-digit code in order for the calculations to work on layout 2.

     I tried limiting the drop-down fields to maximum one character with validation, but that doesn't work - Filemaker will then not allow me to change the field contents after initial entry, it just gives me an error message and the option to revert the field back to the original, even if I try to delete the contents before changing the field.

     I also tried validating with the calculation Left (FieldName, 1), but that still adds spaces to the one-digit codes whenever a field is changed. 

     Thanks in advance - any suggestions appreciated.

Outcomes