4 Replies Latest reply on May 7, 2010 12:38 PM by philmodjunk

    missing data from fields

    dshaw

      Title

      missing data from fields

      Post

      i have 2 data bases where data with a field has randomly disappeared - ie not all records are affected just some some of them [8 out of 500]

       

      i am using FMP10 in max osx 5.5.8

       

      dan

        • 1. Re: missing data from fields
          philmodjunk

          No way to tell from here without knowing more about your database.

           

          Is this just one field? Is this a field from a related table? User errors or errors in scripts could delete data you didn't expect to see deleted. You'll have to do some sleuthing here to narrow down the possibilities.

          • 2. Re: missing data from fields
            dshaw

            In one database {DB1] the lost field is a large notes field which is not from a related table

            in the other database [DB2]  it is primarily a record number field though some records have lost the name and date of birth as well

            none of these fields are from a related pile 

            the only scripts are fro shifting from one layout to another

            DB2 has  another puzzle

            I had created a clone of the data base and imported a subset of records. Then I decided I din’t need it and deleted the data base. 

            There seems to have been a link between these two. Prior to deleting the cloned DB I could not open one without opening the other. 

            Since deleting the cloned DB there doesn’t’ seem to be that problem 

            it is not clear to me when the lost fields started to appear but I discovered the problem in both DB at about the same time. DB 1 has not been changed cloned or tweaked in any significant way [aside from adding a field or two] for several years. 

             

            any clues about where to look to solve this

             

            I do plan to compress the file and then export it to a clone to make sure the file is not corrupted - but befoe I do this I want to make sure I am not carrying over the problem 

             

            thanks

            dan

            • 3. Re: missing data from fields
              aammondd

              Check to see if the field is set to select contents on Entry because if it is then its more than likely a use error in the described situation.

              Simple keystroke wiping out the data.

               

              • 4. Re: missing data from fields
                philmodjunk

                "There seems to have been a link between these two. Prior to deleting the cloned DB I could not open one without opening the other."

                 

                That's exactly what that means. THere was a reference to at least one table in your cloned file in your relationship graph. That opens two possibilities:

                 

                If entire records are missing, the relationship in question could be set to delete related records. Thus deleting a record in one file could automatically delete records in the other.

                 

                Since the files are linked, it's possible that a layout in one file accessed the fields where data is missing, editing this "copy" of the file was actually modifiying the data in the other file.