3 Replies Latest reply on May 31, 2011 11:32 AM by philmodjunk

    Missing Fields in Layout??

    JantzSelk

      Title

      Missing Fields in Layout??

      Post

      Hey Everyone, i just started working on a new database and was plugging away entering new fields through the manage database dialog, but when i got out to start entering new records i found that none of my fields from the dialog box moved over into the layout...? Hoping that someone can help me discover why this happened! Thanks in advance! 

        • 1. Re: Missing Fields in Layout??
          philmodjunk

          There are several possibilities.

          If you have a large number of fields and this layout is a table view layout, their may be too many fields to display them all.

          There's a preferences setting that controls whether new fields are automatically added to the current layout. This option may not be enabled.

          If you add fields to table A and your current layout refers to table B, I don't think you'll see any newly added fields on your layouts.

          You can always enter layoutmode and use the field tool to add fields to your layout. I personnally, leave the "add new fields" preference disabled as I don't want FileMaker to add a field to the current layout as this often changes the design of the field by increasing the size of the body and thus takes more work to correct than just using the field tool to add the fields later.

          • 2. Re: Missing Fields in Layout??
            JantzSelk

            Thanks for the response! I'm still a little lost because i looked into the preference setting and the option to add new fields automatically was enabled so that shouldn't be an issue. I'm wondering if my layout was referring to a different table, when i was adding fields through the manage database dialog. Do you happen to know how i can fix this without deleting and re-entering all of the fields that are already entered? 

            • 3. Re: Missing Fields in Layout??
              philmodjunk

              First, check to see if this is the case.

              In layout setup for your layout, note the name shown in "Show Records From"

              Then check to see if this matches the name in the table drop down in Manage | Database | Fields.

              If not, check on the tables tab to find your table on the right hand side of the = sign. Your layout might be referring to an "occurrence" of a given table. (A table occurrence is one of the "boxes" in Manage | Database | relationships.) If it is, find the actual data source name for this occurrence on the Tables tab and check that table on the fields tab for your fields.

              If you have FileMaker Advanced, you can copy and paste field definitions from one table to another in Manage | Database | Fields to move them to the correct table. I'm not sure if regular FileMaker can do this or not.