5 Replies Latest reply on Aug 22, 2014 4:49 AM by john@outdoorflooring.ca

    Missing Index

    john@outdoorflooring.ca

      Title

      Missing Index

      Post

           I had a relationship which was working fine. When I changed one of the fields used for the link from a text field to a calculation (my bad) I forgot it was used in this one particular relationship. Now I receive Missing Index error message. I changed the field back to what it was previously then reconnected the links (deleting the relationship and creating a new one) and I still get the message. Any ideas what to do?

           Thanks very much

        • 1. Re: Missing Index
          philmodjunk

               I would guess that your calculation refers to either a global field or a field from a related table. Either forces the calculation field to be unstored and an unstored field does not have the needed index that your relationship requires.

               After changing your field back to a data field, open field options for the field and click the storage tab to make sure that it does not specify global storage and has indexing turned on.

          • 2. Re: Missing Index
            john@outdoorflooring.ca

                 Thanks Phil I have checked and it is not a global field and indexing is turned on. Is there a "re-indexing function" Should  I repair or recover the file?

                 Thanks for your time.

                 I am in Toronto Canada and signing off for the night but will check back inn the morning.

            • 3. Re: Missing Index
              philmodjunk

                   Or perhaps the missing index message is not due to this field, but another field used as a match field in a relationship or in a "use values from field" value list...

                   That seems more likely than a damaged index.

                   But if you want, you can use advanced recover options to rebuild all the indexes in your file.

              • 4. Re: Missing Index
                RickWhitelaw

                     Or you can go to Define and turn storage off, click ok and then go back and turn storage back on. This should re-index the field. Or what Phil said . . .

                • 5. Re: Missing Index
                  john@outdoorflooring.ca

                       Hi guys. So I turned off indexing off the. Back on. It works. So the lesson here for me has been; be mindful of changing a text field to a calculation and how it relates to the indexing of that field especially when used in relationships.