10 Replies Latest reply on Mar 17, 2011 8:36 PM by YvesMonsel

    Moving objects in Layout mode

    komich

      Title

      Moving objects in Layout mode

      Post

      I am experiencing an annoying problem since upgrading to 11.0v3.  When you drag a field, FP Pro opens "specify filed" dialogue, instead of moving it to a new location as has always been the case. if you drag a group of objects, then it duplicates the objects, leaving a copy at the old location. This behavior us totally counterintuitive. The only way to truly move selected objects is to use arrows, which is very time-consuming.  Is there a setting that can be changed to make FM Pro behave the way all other programs in the world do? 

        • 1. Re: Moving objects in Layout mode
          RickWhitelaw

          Hmmm . . . just tried this and I experienced nothing like what you describe. I assume you're in Layout Mode. When I drag an object or a group of objects, no "specify field" dialog appears. That dialog should only appear when you double-click the field in question. You have something very unusual happening if what you describe is accurate.

          RW

          • 2. Re: Moving objects in Layout mode
            Sorbsbuster

            I think you may have a faulty mouse, and when you click it is making a double-click.  You could try changing the mouse, or change the settings to see a longer interval between clicks to make a double-click.

            • 3. Re: Moving objects in Layout mode
              komich

              No this was not a faulty mouse.  I've done investigation and this whole episode looks bizarre. In addition to field duplication, there was another glitch: when I tried to resize fields buy dragging the corner handle, they have become square with equal sides. The only way to resize properly was to use inspector window and explicitly set the size. Then is switched user on the same computer, and everything was OK.  This gave me a hint to log out and log in again, and voila, this fixed the problem. Simple quitting and restarting the FM Pro that I've tried before did nothing good.  Still no explanation of what was wrong, perhaps FM developers may have a clue.  Anyway, I thank you guys for trying to help.  

              • 4. Re: Moving objects in Layout mode
                philmodjunk

                I seem to remember seeing a very similar report a while back. If my memory is accurate here, and it may not be, the other user eventually identified another app that was interfering. When he removed/disabled that app, dragging a layout object no longer duplicated it.

                • 5. Re: Moving objects in Layout mode
                  FredrikWallenberg

                  I have exactly the same problem ... I'll let you know if I figure out where the conflict is, but it is driving me nuts. I can't reduce the size of layout parts either.

                  • 6. Re: Moving objects in Layout mode
                    YorgiMahtanio

                    When im creating a sales order, in the data entry page i will input the products that I am selling to the customer,

                    My descriptions vary from order to order. So in the layout page can the description be automatically adjustable?

                    Please let me have your advice !

                    I look forward to your reply!

                    • 7. Re: Moving objects in Layout mode
                      YvesMonsel

                      Exactly the same here arghhhh. Any solution? I become crazy!!! With the Magic Trackpad or with an Apple Mouse.

                      15 mins later...

                      Now (AFTER A RESTART) with an apple keyboard and an apple mouse it works like before.

                      But this is not the keyboard or the mouse for me: back to my Tactile Pro Keyboard and Magic Track Pad it still works fine.

                      I tried with all my usual apps, it's impossible to reproduce the problem. I'll let you know if it comes back...

                      • 8. Re: Moving objects in Layout mode
                        komich

                        Write down what other applications are running while you experience this problem, and then quit them one by one and see if it fixes the glitch.  If you will not be able to identify the culprit, do it in reverse order, start them one by one until you replicate the problem.

                        I think PhilModJunk is correct, there may be another application(s) that cause this, because when I logged-off and logged-in again, everything was OK. I've never bothered to investigate which application caused it in my case, I simply don't remember what was running concurrently, will do it next time I see this behavior again. But if you will figure it our, please let everybody know.

                        • 9. Re: Moving objects in Layout mode
                          FredrikWallenberg5579

                          Quitting open applications does not solve the problem. I can however get the problem go away by rebooting, so there is some process running that causes the conflict. I'm not running anything exotic, so it baffles me that there are so few of us that have seen this problem. I have also not seen anything like this in any other app.

                          QUESTION: Is there a modifier key that will cause layout objects to duplicate when you click and drag instead of move? If so that might be what is happening. As far as mice go, I have a brand new mouse and that did not change the behavior.

                          • 10. Re: Moving objects in Layout mode
                            YvesMonsel

                            Pushing option key while draging an object duplicate it. This is the normal behavior.

                            YM