AnsweredAssumed Answered

Network databases not visible on certain machines

Question asked by BenM on Jul 5, 2010
Latest reply on Jul 14, 2010 by RobFisher

Title

Network databases not visible on certain machines

Post

Hi,

Got a slight problem which has us a little bewildered.

We have a (private school) client running Filemaker Pro 9.0v3. We recently upgraded their network hardware and replaced a bunch of older PCs with new ones (HP DC7900 USDTs).

The client has a requirement to connect to a remote server from time to time to access and update census data for their school's governing body. To do that, what they do is initiate an SSH session using Putty to a remote server and log in to the machine (it's a linux box of some description). Once they do that, they then launch Filemaker and the remote databases appear under favourites.

Since we have replaced their machines, this doesn't work. Putty logs in to the remote server fine, but the remote databases don't appear in favourites so they can't access them.

Firstly: we have a slight networking issue to resolve as the old machines work, but only from one VLAN. So potentially there is maybe a port that hasn't been forwarded to the other VLANs or something (port 5003 according to the docs?)

However - the main issue is that the new machines do not see these remote databases at all. We can plug an old machine into the same port and it works fine. Plug a new one in (and we have tried a few), doesn't work. Both machines are using the same XP SP3 image with Filemaker preinstalled (just different drivers injected into them).

Some different things that have been tried include:

- Turn off Windows firewall altogether

- Add machine to DMZ of hardware firewall (they have a Cisco ASA) so it is not blocked by anything

- Try on a different network - we actually unplugged it from the domain and used a 3G wireless card to do the same thing - no difference

- We have done some network logging via Wireshark and it SEEMS as if the HP machines are doing something different with the packets that are broadcast to it. Speaking to our techs this morning they made the suggestion that it looks as if a DNS request is coming in to the local machine and it should be responding with the names of the databases and the localhost IP address (127.0.0.1) but it isn't.

It's a bit of a new one on us as we're not really experienced with Filemaker so don't know what network requests actually happen behind the scenes for the remote databases to appear.

Any ideas or suggestions as to how we continue troubleshooting this - or any questions? Any help would be greatly appreciated. Thanks in advance :)

Outcomes