4 Replies Latest reply on Jan 7, 2010 3:33 PM by LAblackHole

    Network Sharing Difficulties

    LAblackHole

      Title

      Network Sharing Difficulties

      Post

      Hello!

       

      I'm new to the board and have read various posts surrounding issues similar to mine, but have not had any luck resolving my problem so here goes...

      I'll start with some basic info...

      My setup;
      Primary workstation: Mac running OS 10.4.11 and have both FMP9 and FMP10 Adv installed and functioning.
      Laptop: Mac running 10.5.6 and have both FMP9 and FMP10 Adv installed and functioning.

      My environment;
      I am on an office network. The networks for our LA and NYC offices are interconnected, but am not sure exactly how. Though I can tell you if I want to print, I can select which printer and can actually select printers in our NYC offices from my machine here in LA. I have accidentally printed documents from my machine here in LA on printers in NYC so I know this works. Also, we have shared network drives to store files on. Our people in NYC can access it as well as myself here in LA (I access via Finder/Go/Connect to Server using a smb address).

      What I'm trying to do:
      Host my database from my machine here in LA and share it with another user located in NYC that is on the same network. The data is confidential and needs to be restricted to local sharing to avoid any security issues. I am not permitted to use the web publishing features etc.

      Previously, I had the following solution working just fine:
      I was hosting my database on my primary workstation using FMP10 Adv here in LA. The user in NYC was using FMP10 Adv as well to login. No issues, everything worked beautifully.

      I have a new person as my user and now I have an issue:
      I am still hosting my database on my primary workstation using FMP10 Adv here in LA. The user in NYC has changed, and this person only has FMP9 (doesnt own FMP10 Adv). When they use the "Open Remote" dialogue box, I do not appear under the "Hosts" column in the Local Hosts section. I thought that there was possibly some sort of backwards compatibility issue by hosting on FMP10 Adv and trying to Open Remote with FMP9. So to test I opened my old FMP9 on my primary workstation and tried hosting through that. The user in NYC still cannot see me in hosts under "Open Remote".

      I decided to test connecting using my laptop and my primary workstation to try to rule out user error in NYC and this is what I did....

      I connected my laptop via ethernet to my office network and tried different combinations of application versions on my laptop and workstation to connect them to each other.

      Test 1;
      Primary Workstation: Host using FMP10 Adv
      Laptop: Attempt to Open Remote using FMP10 Adv
      Result: Connection works fine, I appear under host and file appears under available. Am able to access and use accordingly.

      Test 2;
      Primary Workstation: Host using FMP10 Adv
      Laptop: Attempt to Open Remote using FMP9
      Result: After opening "Open Remote" dialogue box on laptop, my primary workstation appears under Host list, but the file does not appear under "available files".

      Test 3;
      Primary Workstation: Host using FMP9
      Laptop: Attempt to Open Remote using FMP9
      Result: After opening "Open Remote" dialogue box on my laptop, my primary workstation appears under Host list, but the file does not appear under "available files".

      Test 4;
      Primary Workstation: Host using FMP9
      Laptop: Attempt to Open Remote using FMP10 Adv
      Result: Connection works fine, I appear under host and file appears under available. Am able to access and use accordingly.

      So apparently there is some sort of issue I'm having where FMP9 is refusing to open my database remotely, no matter if I'm hosting using FMP9 or FMP10 Adv. I can connect when hosting using either FMP9 or FMP10 Adv successfully when using FMP10 Adv to login, but cannot login using FMP9 to connect to host. The simple fix would be to update my user in NYC to FMP10 Adv, however that is unfortunately not an option.

      Any help would be greatly appreciated!

      Thanks!<!-- POLLS --><!-- FILES --><!-- SIGNATURE -->