2 Replies Latest reply on Jun 7, 2009 12:40 PM by peacemaker

    No access to my database in the internet (web) with the IP address

    peacemaker

      Title

      No access to my database in the internet (web) with the IP address

      Post

      I published my database using Instant Web Publishing... I tried to access the database with the iMac of my daughter in the same wireless network in my home. That works fine using the URL http://192.168.1.62/ provided in the IWP dialog of Filemaker Pro. Great!

      But this does not work over the internet. To access through the internet I need the IP address of my router, as far as I know. I have the address. But this does not help me nothing. The browser says that there is no connection to this address.

      Can anyone help me? Thanks in advance.

       

        • 1. Re: No access to my database in the internet (web) with the IP address
          pjdiii
            

          When you say you have the router address, is it something like 192.168.1.0?

          If so, that's the routers address from INSIDE your home LAN.

          You need the IP address provided by your ISP.  It's listed in your router config or just go to:

          http://www.whatsmyip.org/

           

          Next step is punching a hole thru your firewall.  You have to tell the firewall(usually built in to the router) to allow access on the filemaker port  591 or port 80.

           

          Hope that helps/

          • 2. Re: No access to my database in the internet (web) with the IP address
            peacemaker
              
            Thank you very much for you hint. I had the rigth IP Adress. But you said right: I have to punch a hole into the firewall (or whatever). I tried many things. In the router configs I found the possibility to turn on static NAT-Address. That was the solution. I had to tell the router where to route (to which computer) someone accesses my network from outside. Now it works fine.

             

            But I just worry about the security issue. I had to turn off the mac firewall in the security system settings. I tried to add FileMaker Pro to the list to which access is allowed. It works only if firewall is completely turned off. Do you think that is dangerous?