AnsweredAssumed Answered

No Records Found Error during Script

Question asked by AdamHorne on Feb 18, 2015
Latest reply on Feb 18, 2015 by philmodjunk

Title

No Records Found Error during Script

Post

I'm running into an annoying error during a script. I've built a Picker Window that when I click on an item it sets a field called "selected" to "1". 


Once I've selected a number of records, I'll run my script.  

The steps are as followed:
    - It goes to a List layout.
    - Shows all records
    - Enter Find Mode
    - Set field "selected" to 1 (I've also tried "1" with mixed results. The field is a NUMBER field, so I shouldn't need the quotes, correct?) 
    - Perform Find

More often than not, I get the error saying no records found... 

Like I stated above, the strange thing is, sometimes it works and sometimes it doesn't.  When I step through the script using the debugger, it works more often. 

It briefly worked using quotes around 1, then it stopped.  It briefly works just using 1, no quotes, then it stops. 

I've tried changing the field type to TEXT and using "x" and has similar results.

Is it possible the script is running too fast?  I'm wondering since it seems to work when I step through it...

Outcomes