4 Replies Latest reply on Oct 12, 2015 12:55 PM by Ellsworth

    Objects Won't Slide

    Mark_M

      Title

      Objects Won't Slide

      Post

      >

      Version = FM12 Pro Advanced

      I'm having problems figuring out why objects won't slide up for me.  I'm working on a new application for the office to do employment documents.  To provide more flexibility I'll have to have some merged paragraphs meaning the letter closing needs to slide up based on the object above.

      Doesn't seem to be working for me.  In the sample file attached there are two layouts, one with the closing (text & sig graphic grouped) and the other with them ungrouped.  Neither changes how the objects slide.

      Any advice?

      >>>>

       

      Capture.GIF

        • 1. Re: Objects Won't Slide
          philmodjunk

          Are you setting a grouped set of objects to Slide up or are each of the individual layout objects set to slide up?

          Key facts about sliding layout objects:

                 
          1. It's only visible in preview mode and when you print/save as PDF...
          2.      
          3. Sliding fields will shrink but not expand.
          4.      
          5. All layout objects below and in the same layout part as the slide/resize field need to also be set to slide up and resize.
          6.      
          7. Objects in headers and footers will not slide.
          8.      
          9. Portals will shrink/slide to fit the number of rows of records, but fields within the portal row will not shrink/slide.
          10.      
          11. Fields will slide up only if Top alignment is specified for it and will slide left only if Left alignment is specified.
          12.      
          13. Consistent side borders are difficult to achieve with sliding fields.
          14.      
          15. In FMP13, hidden objects (”Hide object when”) will slide/resize.
          • 2. Re: Objects Won't Slide
            Mark_M

            Thanks Phil.

            #1 - Understood.

            #2 - Understood

            #3 - Checked and done

            #4 - Understood

            #5 - Not in a portal (for this case)

            #6 - Understood (Had previously tried with no change, but ya they were)

            #7 - Not an issue here because everything was already set to the left side manually (but ya it was checked)

            #8 - Thank you we'll be on FM12 for at least another year before IT upgrades us.

            *******************************************************

            Final Fix - No sure why, but I expected the objects (signature and lower text box) to slide up to the bottom of the upper text box (body of letter).  That wasn't happening.  I received other advice to lower the bottom of the body text box down to the top of the signature graphic and the lowest text box (i.e "John Doe, Executive Director" to just below the sig graphic.  Just drag the sizing handles down, not to add extra returns.

            That works fine.

            As another experiment I put "Sincerely...Sig Graphic...John Doe, Executive Director" in one grouped object of the text and sig graphic, then did the same expansion of the upper (body) text box and that also worked.  Seems that the problem was there was to much space between the body text box and the lower objects for the lower objects to trigger the slide up.  Expanding the upper box fixed it.

            I uploaded a new screenshot, this time I turned a border on so it is easier to see the outline of the objects.  The only change I had to make was expand the bottom of the body box down to the top of the sig graphic and it works now.

            >>>>

             

            • 3. Re: Objects Won't Slide
              philmodjunk

              That was good advice. "Slide up" only affects the layout real estate taken up by the object set to slide up. It has no effect on empty layout space between the sliding objects.

              • 4. Re: Objects Won't Slide
                Ellsworth

                Thanks for this, @PhiModJunk. After jumping FMP versions from 6/7 to v13 (because FMP v7 couldn't open v7 relational files), this is a subtle discovery of changes. In my case, a left-sliding field which had center-aligned text was fine in v7, but the layout broke in v13. Thanks to your item #6 hint, I found changing to left-alignment resolved the sliding problem.

                 

                   -Ellsworth