6 Replies Latest reply on Sep 29, 2010 4:58 AM by miw

    Odd table header behavior

    miw

      Title

      Odd table header behavior

      Post

      I have a table form that works in every respect except for the tabgle header itself which shows what field one is working in (and allows one to sort the table as well as resize the length of the table).  When the table window opens up, the table header is not visible.  If I click where it should be (just above the first reocrd in the table) it will show up but then it will disappear again after I request the header what to do.  It's a plain vanilla table (no alternate colors on rows or anything like that).  My header and footer parts work fine and look fine.  Any ideas?

        • 1. Re: Odd table header behavior
          philmodjunk

          What options have you selected for your layout in layout setup? You have an option for table view that lets you select whether to include the header, footer parts as well as the column headers. To see these settings, select the views tab in Layout setup... , then click Properties next to the table view option.

          • 2. Re: Odd table header behavior
            miw

            I am pretty sure I have them toggled properly:

            Grids: checked for both horizontal and vertical

            Checked:  include header part

            Checked: include footer part

            Checked:  Include column headers as well as checked for resizable columns, reorderable columns and sort data when selecting column

             

            • 3. Re: Odd table header behavior
              philmodjunk

              What happens if you create a completely new layout that refers to the same table? Do you see the same issue? I'm wondering if you might have a damaged file and/or layout here.

              • 4. Re: Odd table header behavior
                miw

                File seems to be ok.  I deleted all records and put them back just fine.  A simple new table layout appears fine; so maybe my layout is damaged?

                • 5. Re: Odd table header behavior
                  philmodjunk

                  It's certainly possible.

                  • 6. Re: Odd table header behavior
                    miw

                    I recreated the layout and still had problems so I tinklered some more.  I figured out that the reason the table header would disappear is that I had a box graphic object (for design effect only) that was in the header part of the layout that also encroached into the body part of the layout.  When I moved that box graphic object only into the header part of the layout, the table headers in the body part of the layout worked fine.