1 Reply Latest reply on Sep 10, 2009 12:46 PM by mrvodka

    Omitting Records from a Sort

    imgaryshap

      Title

      Omitting Records from a Sort

      Post

      When sorting my records by a particular field for a summary report in the "Preview" window,  I want those records where that field is empty to be excluded from the list and report.   Right now, they are simply being pushed to the bottom of the report based on the sort order.  Since that field was empty, the are showing up at the end.   How can I set it were they do not show up at all?

       

      Thanks so much!

       

      -G. 

       

       

        • 1. Re: Omitting Records from a Sort
          mrvodka
            

          You need to omit them from the found set.

           

          Enter Find Mode []

          Set Field [ YourField; "*" ]

          Constrain Found Set[]

           

           

          P.S.

          Another option is to have it all done in the Constrain Found Set step.

           

          Constrain Found Set [Restore], where * is specified for the field.

           

           

          *Edit:  Added P.S.