7 Replies Latest reply on Feb 24, 2014 8:45 PM by bigtom

    Only one file stoped printing.

    bigtom

      Title

      Only one file stoped printing.

      Post

           I have one FMP12 file that is not printing from any layouts. I can print from other FMP12 files and other applications just fine.

           I do have a backup file that is still printing. However I am not sure why this is happening. I am getting an error that the resolution FM is sending is not supported by the printer. The printer is at a resolution of 180x180 (dot matrix) and the file is sending 600x600. Using FMPA12 on OSX 10.8. This is pretty weird and I have no idea how it happened. I would like to know what is causing this if possible. I do not need this happening again. I have looked around and cannot find a reason.

           Any help would be appreciated.

        • 1. Re: Only one file stoped printing.
          philmodjunk

               Best guess is that your file has become damaged in some way if your cannot select Print from the File menu and print from that file when you can do so from a backup.

               You can run a recover on the file and see what is reported. You may want to try the advanced recover options of Copy File Blocks As Is and Delete Cached Settings to see if that clears up the printing options.

               Things to keep in mind about Recover:

               While Recover almost always detects and fully corrects any problems with your file...

                 
          1.           The recovered copy may behave differently even if recover reports "no problems found".
          2.      
          3.           Recover does not detect all problems
          4.      
          5.           Recover doesn't always fix all problems correctly
          6.      
          7.           Best Practice is to never put a recovered copy back into regular use or development. Instead, replace the damaged file with an undamaged back up copy if this is at all possible. You may have to save a clone of the back up copy and import all data from your recovered copy to get a working copy with the most up to date information possible.

                

               And here's a knowledgebase article that you may find useful: What to do when your file is corrupt (KB5421).

          • 2. Re: Only one file stoped printing.
            bigtom

                 Phil, I had a backup that was still printing. I just imported the updated records from the one that did not print and put the backup into service.

                 I could still select print and get all the way through the print process but something went wrong in what Filemaker was sending to the printer from that file and the printer would not print the job. Stopping it with an error for unsupported resolution.

                 I will give all the recovery options a try just to see how it goes on the broken file.

            • 3. Re: Only one file stoped printing.
              bigtom

                    

                   Saved as compacted and no change.

                   Recovered the file and it is working properly. Looks like there was a problem with the cached print settings. A script got changed on another machine to make the script print on the printer over the network. This may have done something to the file stored print setting on the computer the printer is actually connected to.

                   Generally only the machine with the printer needs to print. Now I need to figure out why the printer is not sharing nicely.

                   All is well now and I will keep this in mind if it ever happens again I will recover with only clearing the print settings.

                   Thanks

              • 4. Re: Only one file stoped printing.
                bigtom

                     This problem keeps coming back for network printing. Works fine from one machine only. Talked to FM Tech support about the issue for about 2 hours running tests and they just don't really care. Could not even isolate where the issue was coming from.

                     So any other ideas would be helpful. My next step is to try printing through a windows print server for the printer. This is a nightmare to say the least. I know FM does not make printers, but it seems obvious FM is the only app with the problem. The answer should not be "Buy another printer because FM just does not like the one you have." If every other Mac App prints why shouldn't FM.

                     I also figured out that FMS will not print so trying to run a print script on the FMS13 will not work either.

                • 5. Re: Only one file stoped printing.
                  philmodjunk

                       FileMaker interacts with printer drivers in ways that many other applications do not. Thus a print driver with a bug may perform flawlessly with other apps and not FileMaker. FilteMaker has no way to fix a printer driver when it's what has the problem and when a problem appears specific to a given printer, that's what this will appear to be the cause.

                       The only other option is to check the printer manufacturer's web site to make sure that your copy of their printer driver is up to date. A number of printer specific issues have been resolved when someone noticed a new printer driver, downloaded and then reported their success with the printer back to the thread where the issue had been reported.

                       And with some dot matrix printers, there is more than one printer driver that may work with a given printer model (we used to use an epson driver to print to oki data printers and it worked for us.)

                       With what printer are you trying to print that has this trouble?

                       Frankly, dot matrix printers are an older technology that while stubbornly hanging on in some areas of business and industry, are an older, slower, more expensive way to print than the available alternatives. Note: we use Epson Dot Matrix printers here with FM 10 with no trouble, but if I could get the boss to make just a few changes (he insists on NCR pre-printed forms), they'd no longer be used here.

                  • 6. Re: Only one file stoped printing.
                    bigtom

                         We deal with a service vendor that requires multi-part carbon forms. These are not going away anytime soon. Jsut something we need to deal with.

                         I have also been working with the printer manufacturer and we have the latest driver. They are basically saying if it works with everything but Filemaker its not our problem and refuse to provide any further support. The printer is $1,800.00 Oki ML5650SU-R. I would expect better service for the price at a minimum. Like when they told me I could run continuous feed no problem and then it turns out the Mac driver only allows printing via single sheets. I could live with that since our workflow will support it but no network printing is pretty bad. No iPad printing is bad. Things are proceeding with OKi that hopefully we can upgrade the printer to a model that they swear will work with no hassles and has been tested with Filemaker networks in the past. Well why didn't they tell me that to start with...not sure.

                         Well, the vendor has an online CSV submission system that has so many bugs its not worth using. I spent a few weeks trying to get that to work. They admit is has a number of issues and they made a few changes to to the support the bug fixes for their largest customer 2 weeks ago and it is way more hassle than it looks since it cannot really be automated any more without some proprietary hardware that is not worth investing in for us. Trust me I would be happy to have something that interacted by CSV online as it would be perfect for automating the entire process in a better way.

                         I will keep at it.

                          

                    • 7. Re: Only one file stoped printing.
                      bigtom

                           Update:

                           I tried printing through an XP machine as a print server. The bad news (which is also the good news) is OSX 10.9 no longer supports printing to XP shared printers. The were a few Apple support community discussions about this as seriously disrupted a large number of companies that lost printing when the went to 10.9 and had print servers on XP.

                           This lead me to an issue that OSX has trouble printing to some printers over networks when the OSX name does not match the device name. I replaced OKI DATA CORP OKI MICROLINE 5650SU-R with OKI_DATA_CORP_OKI_MICROLINE_5650SU_R since dot matrix printers are ancient tech from before spaces were allowed many places on a system and the printer has been working well over the network so far, but time will tell if it fails again for who know what reason. 

                           Thanks for the replies Phil. My dad was a big NCR fan, even after we got rid of the typewriters. At one point he insisted on separating  3 piece NCR documents and feeding them by hand through the laser printer and stapling them back together. We finally moved past that.