10 Replies Latest reply on Apr 17, 2011 7:11 AM by JimFolk

    Paragraph format not recognized by Outlook

    scott_m29

      Title

      Paragraph format not recognized by Outlook

      Post

      The recent FileMaker 11v3 update now will connect SendMail to Outlook 2011 for Mac. But it looks like the format for mail is lost now. For example, the Sendmail message in FileMaker that set up like this:

        &
        "Please refer to this job number when inquiring about the status of your job."
        & ¶ & ¶ &
        "Thank you. "

      looks like this in Outlook:

        Please refer to this job number when inquiring about the status of your job. Thank you.


      The entire message becomes one paragraph. Kind of an unhappy result of an upgrade. Anyone else seeing this on a Mac? Any possible solutions?

      thanks, Scott


        • 1. Re: Paragraph format not recognized by Outlook
          Sorbsbuster

          Maybe you just didn't type it in correct detail, but I think it should look like this:


            <whatever before> & "Please refer to this job number  when inquiring about the status of your job.¶¶Thank you."

          • 2. Re: Paragraph format not recognized by Outlook
            scott_m29

            Thanks Sorbsbuster - 

            I tried that, but it still doesn't change the appearance of the text that gets passed to Outlook.

            I also tried 

            "Please refer to this job number when inquiring about the status of your job."
              & "¶¶Thank you."

            No luck. Outlook just doesn't honor the paragraph character. Tried ^p as well, but that didn't work either. The metacharacter for end of paragraph - \r - conflicts with the script sytax. Not sure if that is a fix or not.

            • 3. Re: Paragraph format not recognized by Outlook
              Sorbsbuster

              What happens if you make it:

              "Please refer to this job number when inquiring about the status of your  job." & Char ( 13 ) & Char ( 13 ) & "Thank you."

              • 4. Re: Paragraph format not recognized by Outlook
                scott_m29

                Thanks for your further input and thoughts on this. Your persistence has kept me probing for the solution. Think I got it now.

                If Outlook's default Composing preferences are set to "Compose messages in HTML by default", the message collapses into on single paragraph. If HTML is off, the message is set up with paragraph breaks honoring the Char ( 13 ) characters you suggested, but not the ¶ that I had been using before. This is a major switch from the behavior seen wit Entourage before.

                Here is the example Send Mail script in FileMaker:

                "Hello " & ext_ClientLookup::ci_firstname & " - "
                 & Char ( 13 ) & Char ( 13 ) & 
                "Here is the first paragraph for a job request for " & DIU_10Jobs::REF Job Specs Product & " - "
                & Char ( 13 ) & Char ( 13 ) & 
                "Here is a new main paragraph. We have entered the job and want to advise you the project will be tracked under the job number R-" & DIU_10Jobs::REF JobNumber & ". Please refer to this job number when inquiring about the status of your job." 
                & Char ( 13 ) & Char ( 13 ) & Char ( 13 ) & 
                "Thank you."

                And the result in Outlook when the default is set to plain text (not HTML as default mail composition):

                Hello Scott -  

                Here is the first paragraph for a job request for Binding -

                Here is a new main paragraph. We have entered the job and want to advise you the project will be tracked under the job number R-80059. Please refer to this job number when inquiring about the status of your job.

                Thank you.

                And this is what the same Send Mail script looks like in Outlook with HTML on:

                Hello Scott -   Here is the first paragraph for a job request for Binding - Here is a new main paragraph. We have entered the job and want to advise you the project will be tracked under the job number R-80059. Please refer to this job number when inquiring about the status of your job. Thank you.

                 

                So - that's the answer. HTML off in Outlook. 

                Thanks again for your help Sorbsbuster.

                Hope this spares other users some head scratching.

                Scott

                • 5. Re: Paragraph format not recognized by Outlook
                  Sorbsbuster

                  Using the 'Code' function I just confirmed that 13 is Unicode for Return, but '¶' is Code 182.

                  We're maybe into the distinction between 'Carriage return', 'Line feed', and the combination of both.

                  • 6. Re: Paragraph format not recognized by Outlook
                    msapple

                    I created an account to confirm that this is still an issue with the 11.3 update and that only when you 1) change ¶ to Char ( 13 ) and 2) change the formatting of default email in 2011 to plain text are you able to work around this issue. Any official fix for this would be appreciated. This seems to only affect outlook 2011.

                    • 7. Re: Paragraph format not recognized by Outlook
                      franz@kelsch.com

                      I had the same problem.  Seems the solution was to change Outlook 2011 so new email is not HTML.  You can still use your old send mail scripts and embed '¶' into the text, as before.  It is not necessary to use & Char(13), which would have required make a lot of changes to my scripts.

                      This works for me, with Outllook 2011, if configured by unchecing "Compose messages in HTML format by default"

                      "Best Regards¶My Name"

                      All of my old email scripts now work, without making changes to them.

                      • 8. Re: Paragraph format not recognized by Outlook
                        JimFolk

                        Unchecking the HTML default was a good work around until MS provided the SP1 upgrade. Unfortunately, this no longer works. I've emailed MS about this but to date, no response. Anyone else experiencing this? If so, is there any other work arounds other than setting the HTML preference off per email?

                        • 9. Re: Paragraph format not recognized by Outlook
                          scott_m29

                          The feedback I got from Microsoft's Outlook forum is that Outlook now supports format=flowed text.  I found that if I had Outlook running in HTML mode like I'd normally prefer to do, and the SendMail message from FileMaker arrived in Outlook, if I toggled the HTML Format option under the Draft menu: disabled it, then re-enabled it again, I would have my paragraphs restored like normal.

                          This little menu flipping action looks like it's cryin' out for an AppleScript solution - which, frankly, is not something I have a handle on.  But if anyone else can whip one up, that might fix this version of the issue for those of us who need it.

                          (I do use the venerable QuicKeys, which I set up to do this format quick-switch, and that works fine, but isn't a free distribution kind of solution.)

                          • 10. Re: Paragraph format not recognized by Outlook
                            JimFolk

                            As a short-term solution, I've set Apple's Mail program as the default when I send emails. Mail recognizes FMP's format just fine. I also tried to create a MacTopia Discussion Forum user account to post at MS's support website, but their Create User Account form doesn't work (which should be rather embarrassing for a software developer's website). I'm thinking that upgrading to Office 2011 was a mistake. While Word seems to be okay, Outlook isn't a finished program yet.