1 Reply Latest reply on Dec 9, 2013 6:13 AM by philmodjunk

    Parsing out "," in numbers.

    bigtom

      Title

      Parsing out "," in numbers.

      Post

           So with the database I am moving from Bento to FM12, I ran across the glorious use of thousands separators in Bento. It seems that fields set as numbers all got these. I have a great many number fields such as SNs and Model numbers and other numbers that should not have these commas in them. I can turn them off in basic display but on field entry they show up and on output they show as well.

           Is there a quick way to fix this or do I need to work through a parsing script to get this done. FM12 seems to handle this situation fine for new entries but the  imported ones are the trouble.

        • 1. Re: Parsing out "," in numbers.
          philmodjunk

               The commas were imported into FileMaker along with the data. You can use Replace Field Contents to clean them out of the field.

               Save a copy of your file (Just in case you make a mistake with this update)

               Show All Records
               Click in the field, select the calculation option and use this calculation expression to strip out all non numeric characters:

               GetAsNumber ( YourFieldHere )