4 Replies Latest reply on Sep 15, 2009 4:07 AM by lamp

    password for a layout

    lamp

      Title

      password for a layout

      Post

      Dear All,

       

      I have a database with 3 tables one of table hase confidential data I want to make that layout hide from view everybody. Is there any way to give password just for one layout?

       

       

      Thanks in advance

       

      Lamp

        • 1. Re: password for a layout
          philmodjunk
            

          In Manage | Accounts & Privileges... you can edit an account's privilege set to deny access to a specified layout. This is the "best practice" for limiting layout access. If you have scripts that take a user to the layout, they can check the results of get ( PrivilegeSetName ) and display a custom dialog informing them that they don't have access.

           

          A much less secure alternative, is to control layout access with a script and use Show Custom Dialog with an input field formatted with the password option. Your script would capture the entered password in a global field and validate it to determine if they are permitted layout access.

          • 2. Re: password for a layout
            comment_1
               If a table has confidential data, use Accounts & Privileges to deny access to the table - not to a layout of the table.
            • 3. Re: password for a layout
              lamp
                

              Thanks a lot for reply.

              I created two account one admin with Custom Privilege with no password and another account Lamp with full access and password.

              Admin account doesn't have any password when I open the database it opens as admin. In this account I disabled one of the tables to no access.

               

              When I close the database and reopen it   it works as normal I can go to disables table and I can make changes.

               

              Regards

              Lamp

              • 4. Re: password for a layout
                lamp
                  

                I found the solution.

                I cleared the check box in File->File Options 

                Now I get prompt to login 

                 

                Thaks a lot for your support