2 Replies Latest reply on Feb 21, 2015 7:39 AM by tays01s

    Pasting text

    tays01s

      Title

      Pasting text

      Post

      Unlike many posts, I can paste into an FM text field, but it defaults to Times Roman or similar. This happens even if I specifically format as Tahoma (or whatever) prior to pasting. Oddly I can get the text to change colour in FM and if I type directly into the field, formatting is as set.

      How can I get pasted text to format/reformat as per FM settings?

        • 1. Re: Pasting text
          philmodjunk

          When you paste from the clipboard, the formatting is pasted with the text. This formatting, along with formatting applied to data while in Browse mode, supersedes formatting specified for the field object while in Layout mode. 

          If you specify this auto-enter calculation:  TextFormatTemove ( Self ) and clear the. "Do not replace..." Check box, all such formatting will be removed when you exit the field. 

          To clean up existing data, you can use the same function with Replace Field Contents, but with the actual field name in place of Self. 

          • 2. Re: Pasting text
            tays01s

            Brilliant......as usual.