2 Replies Latest reply on Oct 25, 2013 2:49 PM by kuhoodva

    pdf insert not working as expected with os X Maverick

    kuhoodva

      Title

      pdf insert not working as expected with os X Maverick

      Post

           Mac OS X Maverick 10.9

           FMPA 12.0.v5

           I have a script that I'm working on that involves saving a record to pdf, emailing that pdf, then putting that pdf in the clients file in a container. Currently the pdf files are being stored externally from FMP in our old file structure on an external drive, but would like to bring them in to be stored in containers. When running the script with the Insert pdf script step it comes up with an error 100, File is missing. I have verified the file is located where it is suppose to be. If I remove source from the script step and let the window open to select the file, I can go to the files location, select it and it works without error.

           $FileTemp; "filemac:" & Get ( TemporaryPath ) & Detail::C_Last Name & Left ( Detail::C_First Name ; 1 ) & ".pdf"

           Save record as PDF [Restore; No dialog; "$FileTemp"; Records being browsed]

           Go to Field [<table>::<field>]    ***This field is a container field set for interactive content***

           Insert PDF ["$FileTemp"]        ***This way giles the 100 error***

           Insert PDF []                           ***This way produces the manual way to find the file and works***

            

           Any suggestions would be great.

           Thanks

           Kurt

        • 1. Re: pdf insert not working as expected with os X Maverick
          philmodjunk

               Does the location where you save the PDF make a difference? As a temporary test, what if you use Get ( DesktopPath ) instead of Get (TemporaryPath)?What if you use "file:" instead of "filemac:"?

               Neither of these should make a difference, but if they do, they may provide a key clue in helping TS folks isolate the cause and may also identify work arounds.

               Also, have you created a small brand new test file on your system and tried out this same script in it?

               All of this, BTW, should be reported over in the Report an Issue (see tabs at top of this screen) section of the forum. You can include a link to this thread in your issue report if you want to save some typing.

          • 2. Re: pdf insert not working as expected with os X Maverick
            kuhoodva

                 Thanks Phil,

                 You lead me to the right answer with your first statement of file vrs filemac. When I took a closer look at the dialog in the "Insert PDF" script set it is looking for a "image: or imagemac:" instead of "file: or filemac:"

                 I replaced my filemac: with imagemac: and it works fine now. I guess I wasn't observant enough until you guided me there.

                 Thanks again