9 Replies Latest reply on Jun 18, 2010 1:56 PM by philmodjunk

    Portal Help

    LuisN

      Title

      Portal Help

      Post

      How come i have 1 portal and its showing all the drop down menus, etc.

       

      but on another portal which i am showing the correct related records from another table but in layout mode it has the drop down menus, but in the browse mode they disappear?

        • 1. Re: Portal Help
          LuisN

          Just an update, i have been on this for about 6 hrs. and i check over each relationship and its all fine (as far as i now) and still doesnt show the fields when in browse mode =(

          • 2. Re: Portal Help
            Steve Wright

            Have you checked the fields are within the boundaries of the first portal row ?  If you are 1 pixel out, you will have this problem.

            • 3. Re: Portal Help
              LuisN

              Yeah what i tried was moving it out a little of the portal and you can then see it. the minute it goes within the portal it goes all white all i see is the portal.

              • 4. Re: Portal Help
                Steve Wright

                That suggests to me there is a problem with the relationship, no related records are showing and by the sound of it, the relationship is not set to allow creation of related records.. If it was set to allow creation of related records, you would see the first row..

                 

                 

                 

                • 5. Re: Portal Help
                  LuisN

                  WOW!!!! why the heck didnt i see that!?!??!

                   

                  ok now 1 thing thou, it lets me select , drop down etc. BUT when i click outside of the portal. the data from the drop down dissppear!?!?!

                  • 6. Re: Portal Help
                    LuisN

                    So this is def working, but the fields disppear when i click outside of the portal =(

                    • 7. Re: Portal Help
                      philmodjunk

                      Check the relationship set up for your portal and (If using filemaker 11) any filter you've set on the filter.

                       

                      If, after editing the fields, the portal record is no longer related to your layout's current record it will disappear. Likewise, a portal filter could exclude the modified record if you are using filemaker 11.

                      • 8. Re: Portal Help
                        LuisN

                        I am about to crazy b/c Phil it worked after i created 1 field in each table and associated them instead of associateing a field that is actually doing something. so 2 blank fields in the relationship worked fine.

                         

                        Thanks !!!! how do i mark all this as the solution?

                        • 9. Re: Portal Help
                          philmodjunk

                          When you review this thread, you'll see a grey button next to the reply button in the bottom right corner of every post except the first one. Just select the post that you see is the solution post and click the button.