5 Replies Latest reply on Jan 10, 2013 3:17 PM by RichardLawrence

    Portal shows imported records but does not allow new entries

    RichardLawrence

      Title

      Portal shows imported records but does not allow new entries

      Post

           I have been using Filemaker Pro 11 for a couple of years for simple tasks such as Contact List and Product Catalog. Our company has an old Access 97 database with Visual Basic interface that has become corrupted and a security risk. I have managed to export the table data and build a new file. All of the historic records that I imported show up in the portal window, but when I select "New Record" I have blanks available for all of the data but no ability to enter new items in the portal itself. I have attached an image of the page. Your help would be greatly appreciated.

      PO_Page_sample.png

        • 1. Re: Portal shows imported records but does not allow new entries
          philmodjunk

               It sounds like you need to:

               Open Manage | Database | Relationships

               Find the relationship between the layout's table occurrence and the portal's.

               Double Click the relationship line linking the two.

               Select "allow creation of records via this relationship" for the portal's table occurrence.

               (Tutorial: What are Table Occurrences?, are what we call the "boxes" found on the relationships tab in Manage | database. They may look like "tables". They are frequently called "tables"--even in numerous places within the FileMaker application, but they really aren't tables.)

          • 2. Re: Portal shows imported records but does not allow new entries
            RichardLawrence

                 Thank you for your quick response. I'm not sure what I should be linking in the two databases from your answer. I have attached an image showing my table relationships. Perhaps you can provide some more definitive comments based upon this.

                 Richard Lawrence

            • 3. Re: Portal shows imported records but does not allow new entries
              philmodjunk

                   If you go to layout setup for the layout you've shown, I'd expect to see "PO Table" in the "Show Records From" drop down in Layout setup..., In layout mode, you will also see this text to the right of "Table:" in the status toolbar at the top of your screen. If you open portal set up for your portal or just inspect the text shown in the lower left corner of the portal when in layout mode, I predict that you'll see "Line Items".

                   Assuming that is the case, double click the = sign in Manage | database | Relationships on the line linking PO Table to Line Items. You'll find a check box for "allow creation" for both PO Table and Line Items. Select this checkbox for "Line Items".

              • 4. Re: Portal shows imported records but does not allow new entries
                philmodjunk

                     As I was leaving this thread, I just noticed another potential issue that could be a factor:

                     What field options, if any, have you selected for k_ID_PurchaseOrderNo? And what kind of data have you imported into it?

                     In most FileMaker Databases, this field would be setup as an auto-entered serial number and if you have imported a serial number into this field, you'd need to specify a next serial value greater than the largest value imported into this field. In FileMaker 12, this could also be a text field set to auto-enter the value returned by Get ( UUID ).

                     Without a value in this field in your new Purchase Order record, you will not be able to enter any data into the fields in the portal so you need to set up the necessary auto-enter field options for this field in addition to what I have already recommended.

                • 5. Re: Portal shows imported records but does not allow new entries
                  RichardLawrence

                       Your suggestions solved my problem. Silly mistake to make. Thanks again.