1 2 Previous Next 16 Replies Latest reply on Apr 15, 2009 2:09 AM by Orlando

    Portal vs Fields mystery

    synergy46

      Title

      Portal vs Fields mystery

      Post

      I give up.  I can't figure out what the 'feature' or 'rule' of FM is regarding dragging fields onto a portal.

       

      Sometimes they end up behind the portal.  No amount of "bring forward" or "bring to front" moves them to the front.  If I drag them off the form and then drag them back on again... say 1/2 way, the field appears to be on top..... until I continue to drag it all the way onto the form then it promptly goes behind the portal again.   

       

      There must be some little 'rule' or characteristic of FM that I am missing???

       

      I am running FM 10 advanced on OSX..

       

       

        • 1. Re: Portal vs Fields mystery
          Orlando
            

          Hi synergy46,

           

          Is the portal inside of a Tab panel? The only time i have experienced what you describe is if the portal was slightly outside a tab panel, even by 1 pixel, and the field was being placed on the portal inside the tab. So if you do have a tab panel on the layout double check this.

           

          I hope this helps.

          • 2. Re: Portal vs Fields mystery
            synergy46
              

            Yes, the fields are ENTIRELY inside the top row. The crux is that if I drag a field off the form, release the mouse and then click it again and drag it 1/2 way into the top row it shows itself as on top.  But if I continue to drag it ALL THE WAY into the top row, it goes behind???????!!!!!  grrrrrrrr

             

            The only solution I can affect is to delete the portl.  Create a new one.  Designate the fields and THEN they show up on top.

             

            It is just mildly annoying to have such a feature be so 'counter intuitive'.  Not a big deal.

             

            Thanks

             

             

            • 3. Re: Portal vs Fields mystery
              Orlando
                

              Is it possible to post a screen shot of the layout?

              • 4. Re: Portal vs Fields mystery
                synergy46
                  

                Here you go:

                 

                http://ronaldogordono.googlepages.com/portal

                 

                Got any ideas?

                 

                Thanks

                • 5. Re: Portal vs Fields mystery
                  TSGal

                  synergy46:

                   

                  The portal and screen shots look fine.  Either the portal is corrupt, or there are no related records for the current record.

                   

                  If you create a new portal and the records show, then the portal is corrupt.  If the records don't show, then there are no related records.

                   

                  TSGal

                  FileMaker, Inc. 

                  • 6. Re: Portal vs Fields mystery
                    philmodjunk
                      

                    Using FMP 10 adv,

                     

                    I tried duplicating your issue. I dragged a field off a portal, saved the change, cycled from layout to browse to layout mode, dragged the field back and there was no problem. The field stayed part of the portal and did not drop behind it.

                     

                    I tried dragging the field off, locking the portal and then repeated the above steps. Even with the portal locked, I had no problem putting the field back into/onto the portal.

                     

                    What happens when you open up a brand new file and try to recreate this? Is it repeatable?

                    • 7. Re: Portal vs Fields mystery
                      synergy46
                        

                      If I could predictably reproduce the problem then I could figure out what the 'rule' is or what I am doing wrong.  The problem is seemingly random in it's occurance; ie, it just 'happens'.   Most times I just delete the portal, recreate and everything is fine.  With the pictured example, I got the portal fields to show on the portal but they won't show records....  I will check the portal setup and make sure everything is as desired...again.

                       

                      • 8. Re: Portal vs Fields mystery
                        philmodjunk
                          

                        Sorry to ask the obvious, but...

                         

                        What do you see when you double click the field while in layout mode? Does the field come from the same Table Occurrence you specified for the portal?

                        • 9. Re: Portal vs Fields mystery
                          synergy46
                            

                          I made the field background Gray and it does not show.  Additionally, I can not click the field in layout mode because the field is not there?

                           

                           

                          • 10. Re: Portal vs Fields mystery
                            TSGal

                            synergy46:

                             

                            Would it be possible to send in your file?  If you want, pull down the File menu and select "Save a Copy As..." and select for Type "clone (no records) ".  This will make a copy of the file without any data.

                             

                            I will then look at the layout, determine what is the problem, and get it back to you.

                             

                            I have sent you a private message (top of this page - right side - X Messages) with instructions where to send the file.

                             

                            TSGal

                            FileMaker, Inc. 

                            • 11. Re: Portal vs Fields mystery
                              mfwills_1
                                

                              Two questions:

                               

                              1. Are there, in fact, related records which should be showing up?

                               

                              2. In the relationship setup, do you permit creating records in THAT table from THIS one?

                              • 12. Re: Portal vs Fields mystery
                                philmodjunk
                                  

                                synergy46 wrote:

                                I made the field background Gray and it does not show.  Additionally, I can not click the field in layout mode because the field is not there?

                                 

                                 


                                 

                                The field is not there? That doesn't make sense to me. If the field wasn't there, you would not be posting that the field is disappearing behind the portal. When you drag a new field onto the layout, the specify field dialog will pop-up for you to select a table occurrence and a field. Is that what you are doing or are you dragging a field that you have already placed on your layout to a new location? Either way the field should be there somewhere.

                                 

                                The only time that doesn't happen for me is when I drag a new field onto the layout and accidently release the mouse button when the mouse pointer is not over a layout part. (It's pointing at the status bar, outside the filemaker window or down off the bottom of the layout.)


                                • 13. Re: Portal vs Fields mystery
                                  Orlando
                                    

                                  Hi synergy46,

                                   

                                  Have you got to the bottom of this yet, did you post a file to TSGal and have you got an answer?

                                  • 14. Re: Portal vs Fields mystery
                                    TSGal

                                    All:

                                     

                                    synergy46 did send me the file.

                                     

                                    A common mistake.  The field in the portal was from the current table; not the related table.  Changing the field to the related field worked properly.

                                     

                                    I sent a reply along with the updated file to our Technical Support liaison, and he verified it was sent out yesterday.  If you have not received it, please let me know.

                                     

                                    TSGal

                                    FileMaker, Inc. 

                                    1 2 Previous Next