11 Replies Latest reply on Nov 17, 2010 10:35 AM by RuthPorter

    Print problems with Xerox Phaser

    Adrian99

      Title

      Print problems with Xerox Phaser

      Post

      Having just purchased a Xerox Phaser 8560 printer I find that my Filemaker 9 tried and tested layouts are no longer printing correctly.  All of the text and numbers (whever layout info or field info) prints okay and in position BUT no lines, (or field borderlines) or boxes print in positon, - these are all reduced by 50% and printed top left on the page.  I have redone layouts, made countless test files but all lines,borders & boxes will simply not print as they should. What's going on ?

        • 1. Re: Print problems with Xerox Phaser
          mwc_1
            

          I'd make a PDF first, see if that views/prints OK...if so i'd really put your print driver/setting for that unit at suspect.

          • 2. Re: Print problems with Xerox Phaser
            Adrian99
              

            Hi -  Pdfs view and print fine - the printer prints from every other application I have without any noticeable problems.  At the risk of complicating things I do have a further oddity to add - I have one single Filemaker file that I use from which everything prints perfectly ( for now)  - one out of maybe some 50 or 60 files.

            Anyway it's all very strange but unfortunately I have to get it sorted out somehow.  If it is a odd conflict between Filemaker and the Xerox printer with whom does the problem lie ? Maybe I'll try re-installing the print driver ?  Any comments or suggestions are very welcome.  Thanks

            • 3. Re: Print problems with Xerox Phaser
              TSGal

              Adrian99:

               

              Thank you for your post.

               

              If it works fine in one file but not out of the other 50, it doesn't sound like a printer driver problem but more FileMaker Pro related.  If it was a print driver problem, it would fail every time.

               

              However, on that one file, is the layout simpler than the other files?  That is, are there less graphics, information, text, etc. than the other files?  I'm wondering if the print queue is getting overloaded. 

               

              If it works fine for PDF, then at least the information is being sent properly to the PDF file.  

               

              There is a print preview in the print dialog box.  Does that also look like it should?  Whatever displays in preview is the same as what is sent to the printer driver.

               

              Are you printing a page range?  Printing current record?  Records being browsed?

               

              Any additional information you can supply may help narrow down some of the possible causes.

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: Print problems with Xerox Phaser
                Adrian99
                  

                Hi - thanks for your help on this.

                 

                The file that is printing okay is our largest and most complicated file, more tables, layouts etc than the others - It is , what I would call our 'main' file.   At the risk of getting tedious I'll just briefly explain -

                 

                This main file is copied at the start of a new month, renamed and records from several tables are deleted - ready for the new month.

                The January 'main' file was the one we were using when we purchased the printer - it worked fine - but all the previous month's files, of which this was the ongoing copy, didn't print correctly. 

                In February a copy of the January file was made- this prints fine too.

                We also have many ongoing files, several of which have a relationship to our 'central' file- none of these print correctly.

                 

                To go through your points - all print previews display the correct view - the print error occurs regardless of whether it's current record, range of records or records being browsed.

                 

                The print error occurs from all our three computers and it occurs on Filemaker 7 and 9 and also on the trial version I have of Filemaker 10!

                 

                At the moment I'm thankful this one main file is printing properly. There must be some clue in the fact that this file was the one I used when the printer had its first run ?

                 

                Thanks again.

                 

                 

                • 5. Re: Print problems with Xerox Phaser
                  TSGal

                  Adrian99:

                   

                  Thank you for the additional information.  Even though I don't have an immediate answer, it helps narrow down the possible causes.

                   

                  We definitely agree that there is "something" different between the two files.

                   

                  My gut feeling is to perform the following steps:

                   

                  1. Open one of the files that is not printing properly.

                   

                  2. Go into Page Setup (Mac) or Print Setup (Windows) and select another printer.  Click OK.  This resets the printer information for the file.  Just to be sure, close the file.

                   

                  3. Reopen the file, go back into Page/Print Setup and select the original printer.  Click OK.

                   

                  4. Go to Print, make sure the proper printer is selected and print from page 1 to 1.  See if this works.

                   

                  If this doesn't work, can you try printing to another printer?  If so, does that work?

                   

                  Please continue to keep me posted.

                   

                  TSGal

                  FileMaker, Inc. 

                  • 6. Re: Print problems with Xerox Phaser
                    Adrian99
                      

                    Hi

                     

                    Thanks for the suggestions - unfortunately the print error remained. 


                    I came in this morning and picked up your post - opened an old month file that I knew hadn't been printing - tried your suggestions but the print error remained.  I tried another file but again no change.  Both files printed perfectly to another printer.  

                     

                    Then - I opened our current month main file - the one that was okay - and that is now no longer printing correctly!  So currently, and very strangely, no Filemaker files are printing correctly on the Xerox.

                     

                    I appreciate your continued help with this - I know there are always countless variables to think about.  I've sort of run out of ideas myself.  As and when I get the chance I'll try different things and certainly let you know if anything changes.

                     

                    Many Thanks

                    Adrian

                    • 7. Re: Print problems with Xerox Phaser
                      diquito
                        

                      Is it a network printer or is it connected to the computer directly?

                      If it is a network printer try to fool the OS/Filemaker by creating a local print port that you redirect to the networked printer and the set the filemaker client to print to the local print port.

                       

                      :smileyvery-happy: 

                      • 8. Re: Print problems with Xerox Phaser
                        hiatts
                           before going on the hunt.. make sure you have the latest driver from xerox, and make sure the correct driver is installed, usually PostScript (PS, not PCL).
                        • 9. Re: Print problems with Xerox Phaser
                          Adrian99
                             Yes I've downloaded the latest driver and re-installed a couple of times on different computers but results are always the same.   Thanks for the suggestion.
                          • 10. Re: Print problems with Xerox Phaser
                            mwc_1
                              

                            This sounds like it is abosolutely a print driver issue not interpreting the FM data properly.

                            What language is the print driver using (PS-postscrint,CUPS,PCL, etc.....?) is there an option to use a different one?

                            I would see if you can use another print driver or a generic print driver to hit the printer with.

                            Also, if you are limited to the Phaser driver - open up the options and see what you can change....B/W vs. color, print language...etc....try different settings.

                             

                            What OS are you printing from?

                            • 11. Re: Print problems with Xerox Phaser
                              RuthPorter

                              We had exactly the same printing issue with a Xerox Phaser 6360 printer and have found a fix for it. 

                              In FileMaker, go into File, Print and then the properties of the printer.  On the Paper Output tab, find the Saved Settings option at the bottom.  Ours said Filemaker defaults.  Change this to Driver Defaults.  Everything printed ok after that.  You should delete the Filemaker defaults from the list to stop it appearing as the default setting each time you print. 

                              Hope this helps

                              Ruth