7 Replies Latest reply on May 14, 2013 3:26 AM by LibanonLyceum

    Printing can not continue...use control panel to set up a port

    Steve Wright

      Title

      Printing can not continue...use control panel to set up a port

      Post

      I have just had a call from one of my clients who is experiencing an issue when trying to print from Filemaker 10 V3

       

      Their OS is Windows Vista 64

      The printer is a Brother MFC-6490CW printer

      Connected to a local USB port  (set as USB002 Virtual Printer Port)

       

      Error Message Received :

      "Printing can not continue because this printer is not connected to a port.  Use the Control Panel to set up a port."

       

      In all my years working with FileMaker, I have never come across this issue, however it is only FileMaker having the problem.

      I use Vista x64 myself and do not have such issues (with a similar configured port setup)

       

      Printing from any other application works without an issue, print jobs are added to the que and printed as expected.

      I have removed the printer & port and re-installed to no avail.

      I have tried changing to various other ports, putting the printer in a paused state to test, but still nothing gets added to the que.

       

      The file is being run locally, this message appears when choosing File > Print

      The printer is showing correctly in the list, clicking properties brings up the printers own config menu's

       

      Any ideas / thoughts / things to try are more than welcome !

       

       

       

        • 1. Re: Printing can not continue...use control panel to set up a port

          SWS:

           

          Thanks for your post.

           

          Printer issues are generally very hard to troubleshoot, but there is one thing I would strongly suggest. FileMaker Pro is not tested or certified to run on a 64 bit version of Vista. As it sounds like you've tried alot so far, see if the client you are working with can install a 32-bit version of Windows to one of their systems as a test, and hook up their printer with the latest version of the printer drivers. This may not correct the issue, but it will take out the 64-bit compatibility as an issue.

           

          Behavior is very unpredictable on 64 bit version of both Windows Vista and Windows 7, and only some users may have the same issue while others may not even be able to install correctly. Currently our only certification on 64 bit versions of Windows is Windows Server 2008 running either FileMaker Server (Advanced) 10 or 11. We have not been able to get reliable enough behavior of any Pro or Pro Advanced on 64-bit versions of Vista or Windows 7 to be fully certified, nor can we predict their behavior.

           

          Please keep me updated on this issue so I can offer further advice to give your client.

           

          TSRaven

          FileMaker Inc.

          • 2. Re: Printing can not continue...use control panel to set up a port
            Steve Wright

            Thanks for the reply TSRaven.

             

            Thankfully, I managed to resolve this issue (not too long ago) through a lot of trial and error.

             

            I think the steps that solved it where :

            I removed the printer drivers completely (including any temp files left over & for ALL printers installed)

            Removed the Virtual USB ports

            Rebooted the machine

            Re-Installed the printer driver 

            Immediately opened up FileMaker and performed a print test.. it worked fine

             

            So then I continued to add the other printers back, testing along the way.

             

            • 3. Re: Printing can not continue...use control panel to set up a port
              SecretWeaponLabs

              I just had this issue crop up with a client whom I built a v11 runtime solution for and she's using the solution in Win7 with a Brother 2140 printer.  I'm struck by the fact that this is a brother printer in the aforementioned case.

              However, I tried uninstalling the two printers installed using the Devices & Printers control panel (I don't know about temp files and where they're located though), had them unplug and replug the printer, reinstalled the printers and it worked for a week and it has now returned.  The client said she did not do anything differently to trigger the issue and I'm at a loss as to what to suggest.

              Anyone have any ideas?

              Thanks

              • 4. Re: Printing can not continue...use control panel to set up a port
                DennisGoldsberry

                I started to get this error message after using FM Pro 11 with Windows 7 successfully for 6 months.  I tried the above solution and it worked for a little while (although it was a pain due to the number of printers I use between home & work).

                The simple solution is to set the program to run in "Compatibility Mode" for vista.  To do this, go to the Filemaker folder inside the Program Files (x86) folder.  Find the executable file and right-click.  Select Properties, then the Compatiblity tab.  Click on the "Run this program in compatibility mode for:" and select Windows Vista.

                I would assume this would also work for a runtime solution by setting the compatibility mode for the executable file.

                • 5. Re: Printing can not continue...use control panel to set up a port
                  Tricia

                   I am using windows 7 on a 64 bit machine. I have tried many many things...compatibility settings, uninstall printers, etc.. Nothing seems to work except shut down FMP and log back in and then it will print once. I have to do that every time. It's very frustrating. Makes being productive in a timely manner hard. I have used Filemaker going way back to version 3 and I love FM, but this is making me want to find other programs. Please FileMaker fix this issue. I would hate to be forced to cheat on you.

                  • 6. Re: Printing can not continue...use control panel to set up a port
                    LeonXu

                         Hi There,

                          

                         I am having the same issue with 64 bits Windows 7. This message came up only when I print to a particular photocopier (Fuji Xerox DC II 7000) from Filemaker Pro 11. However, I can print Word doc or PDF to the same photocopier though. There is no driver issue. Would you provide a fix for that?

                          

                         Thanks,

                          

                         Leon