2 Replies Latest reply on Jan 18, 2011 11:23 PM by RossanoIennarelli

    Problem with an axternal database

    RossanoIennarelli

      Title

      Problem with an axternal database

      Post

      hi all,

      I'm using fmp 11 on a windows xp PC, I'm creating a database divided into 2 files : one with the database and the other one with the structure (format, scripts, etc). I set in "external source file" the file with the database. Until I must only read or modify the record it's all ok but the problem comes when I try to save a new record.

      It is saved in a local table that I can see with the "table format" but not in the data file, how can I do this? I tried to see over the web but I've find no solution. someone can help me??

      thanks in advance to everyone!!

        • 1. Re: Problem with an axternal database
          philmodjunk

          Apparently, one or more of your layouts refers to a data source table that exists in your interface file instead of your data file.

          Open Manage | Database | Relationships in the interface file (File with the layouts, scripts etc.)

          Double click each table occurrence "box" and use the data source drop down to select the correct table from the database copy of the file.

          • 2. Re: Problem with an axternal database
            RossanoIennarelli

            problem solved.

            The issue was the index field, in the exported data they came from 1 to 6, when i tried to add new record from the structure file the index field was restored, I've set that file as unique and during the input the new record was not accepted.

            I deleted all old record from the data file and now the input works great.

            thanks for the time dedicated!!!