2 Replies Latest reply on Jul 28, 2010 3:16 PM by MariahBoyle

    problem with auto enter fields



      problem with auto enter fields


      I have imported data from an excel spreadsheet and then created some auto-enter fields (calculation to concatenate field names, creation date, mod date, and look-up fields). These fields don't popuate when I hit ok, but do populate when I re-import the spreadsheet into that existing table. I'd like to learn how to make those fields auto-enter on creation as I'd like to make changes in the database and not have to keep re-uploading the excel file everything I make new fields...anyone have any suggestions?

      Many thanks,
      Mariah (new user)

        • 1. Re: problem with auto enter fields

          If you've set a field to auto-enter the date on creation it will automatically enter the date for each new record you create via filemaker. If you import data from another source, such as an excel file, this date will also be auto-entered if you select that option during import.

          Thus, I'm a bit confused as to what you mean by "These fields don't popuate when I hit ok,..." The OK button appears in all kinds of dialogs so I don't quite know which dialog you have open when you click OK and the field doesn't populate.

          Please keep in mind that auto-enter settings won't affect records that are already in the database at the time you select the auto-enter settings for a field. In those cases, you'd need to use a method such as Replace Field Contents to update the field in the previously existing records.

          • 2. Re: problem with auto enter fields

            Thank you, I think the Replace Field Contents step is what I was missing as I had already imported the file. I will give that a try now!