2 Replies Latest reply on May 16, 2014 11:12 AM by fredmckinnon

    Problem with Imports from Excel

    fredmckinnon

      Title

      Problem with Imports from Excel

      Post


           Hey Gang,

           I've been having this trouble for quite some time and finally got frustrated enough to post for help.

           I'm using FileMaker 11.0v4.  I connect remotely to a FM web server.

           My issue is with importing.  I have to do a lot of imports of FedEx and UPS bills where the Order # on the bill matches the order # in filemaker, it adds the shipping amount for us.

           What happens almost 100% of the time is that I do the import, and even though I have the matching field indicated, it doesn't notice/match the entries, so it creates all new entries for every row in the spreadsheet.   EVERY TIME, even though the fields match perfectly.  

           I then "delete all found records" and run the import again, exactly the same without doing anything differently, and everything matches and syncs up and the import works perfectly.

           What could be causing this where it fails on the first attempt, every time --- and then, works flawlessly on the 2nd attempt ... every time?

           Just to summarize:

           Import Records > File > Update Matching records in found set
           (add remaining data as new records is checked, as is don't import first record)

           My matching field is enabled (arrows pointing in both directions) to the correct target field.

           Click import -- it runs (it seems to run very quickly, btw) and completes, saying NO ERRORS, yet, it didn't match anything and created 100% new records.

           Delete found all records in found set (that were just created w/ the import)

           Go back to Import Records - and do the same exact thing w/ the same exact file without modfying anything, it works 100% perfectly.

           Every time.

        • 1. Re: Problem with Imports from Excel
          philmodjunk

               Update Matching records in found set

               What was your found set in the target table at the time that you imported?

               It may be that you need to do a Show All records on the target table occurrence before importing to make sure that all records in the target table are also in the found set.

          • 2. Re: Problem with Imports from Excel
            fredmckinnon

                 Phil, Phil,  Phil - why didn't I post this question a YEAR ago!  That's the problem.  In most cases, I always had some found set from searches prior to uploading.  I guess I just never paid attention, or assumed that it would still search everything, not just the current found records.

                  

                 Can't say 100% if that fixed it, but for the first time in forever, the import just worked perfectly on first try after doing "show all" records.

                  

                 THANK YOU.