10 Replies Latest reply on Jul 22, 2012 7:00 AM by DgWater

    Problem with Instant Web Publishing

    nigelb

      Title

      Problem with Instant Web Publishing

      Post

      Hi

      I wonder if someone can help. 

      I don't seem to be able to share files over the internet. I'm using File Maker Pro 12.

      Originally I had got a file shared and a colleage was entering data using the internet, now I can only get the Instant Web Publishing list of files page on a computer that is accessing the internet through the same interet connection as my host computer.

      On these computers the URL is in the format: http://192.xxx4/fmi/iwp/res/iwp_home.html  Am I right in thinking this must be being shared through Network Setting and not Instanst Web settings?

      I think I have sharing Instant Web Sharing  set up correctly (see attached jpeg) and it was working originally. I'm not aware of changing any of the settings. I have changed the layouts on the database I am sharing, but I don't seem to be able to share any files.

      I'm a new user, so any help would be very much appreciated.

       

      Best wishes

       

      Nigel

       

       

       

       

       

       

       

       

       

      Capture_FMP_1.JPG

        • 1. Re: Problem with Instant Web Publishing
          JoshuaVijsma

          To access it via the internet, you need to forward port 80 in your modem/router. Also, set your ip adres of your pc which is hosting the webpage to a static ip, so it won't change (if it would change it would cause your port forward to be useless).

          • 2. Re: Problem with Instant Web Publishing
            philmodjunk

            And the IP address would be that of your internet router, not your computer's internal ip address. The router then needs to be set up to forward port 80 requests to the host computer.

            • 3. Re: Problem with Instant Web Publishing
              nigelb

              Hi Both,

              Thanks for the help... I've now done the port forwarding on the router and the hostPC has a static IP. 

              But still no joy. I've tried using the ULR that FMP suggests and tried using the router IP as well. Neither page will load/ I've also tried disabling the comuter's own firewalls. 

              So still stuck! Any more ideas?

              What seems odd to me is that it worked so straightforwardly originally....

              Thanks 

               

              Nigel

              • 4. Re: Problem with Instant Web Publishing
                JoshuaVijsma

                if you restart filemaker, does it display any error messages? 

                • 5. Re: Problem with Instant Web Publishing
                  nigelb

                  no - it seems happy in itself! (and I upgraded to v2 of FMP12 just in case).

                  • 6. Re: Problem with Instant Web Publishing
                    davidanders

                    This is a common question.  A Google for"iwp portforward site:forums.filemaker.com"

                    will return the threads on this site with directions.

                    https://www.google.com/search?q=iwp+portforward+site%3Aforums.filemaker.com

                    • 7. Re: Problem with Instant Web Publishing
                      nigelb

                      Hi all,

                      Thanks for all your help - and I am soretd now. A few things (no doubt well known) that threw me ane might be useful to others.

                      1) To make Instant web publishing work you will have to configer File Maker Pro and your internet router

                      2) The ULR that Instant Web Publishing suggests you use will only work with computers using your internet connection (ie networked in someway to access the internet though your router).

                      3) To allow a computer connected to the internet in another way to use Instant Web Publishing you have to "punch a hole" in your router's broadband settings. That is, you must go into your router's settings (using a web browser - you will need the router's password details) and configue Port Forwarding to work with the computer that hosts your copy of FMP. 

                      This means locating your compuer 9the one running FMP) on the network and adding FileMakerPro as you might a game or other application using Port Forwarding. It sounds scary but it isn't too hard. The port to use if you want to give someone access who doesn't have their own copy of FMP is 591.

                      Once done, you are nearly set. The ULR will be your IP address with 591 appended (and you append it with : -- a colon, not a / or a .)

                      4) So, if you want a user, connected to the internet on their own computer using a completely different internet connection, to access a file in Internet Web Publishing, you use the IP address with the 591 added. But be careful (this fooled me) the ULR is NOT the IP of your host computer (ie the one running FMP). NOR is it the ULR of your router (ie where you go to change the settings on your broadband). IT IS your actual IP address which can be found using a website like http://whatismyipaddress.com.

                      Finally, remember that if you want to access your files through another computer in your set up which does use your internet connection, the address will be the one that FMP gives you - ie the IP address of your computer with the 591 appended.

                      There is one more issue to be aware of. If your broadband provider only gives you a dynamic IP address, you are going to have to live with monitoring wherther your IWP ULR is still working - and changing it to the new IP address as necessary.

                      This is a layman's account so I may have missed things but hope it is helpful. And that you for everyone who pointed me to this conclusion.

                      Nigel

                       

                       

                       

                       

                       

                       

                       

                       

                       

                      • 8. Re: Problem with Instant Web Publishing
                        leolijs

                        Hi Nigel,

                        Time ago have once a similar problem, I have changed the port to 84 or 86 and of course also have forwarded the port on the router, try yhis maybe it can solve your problem, since then it's work very fine on my mac and pc. ( maybe there is a problem with another soft using port 80 ). ( vieuw attached foto ).

                        rgds.

                        Leo

                        • 9. Re: Problem with Instant Web Publishing
                          davidanders

                          Thank you, Nigel for verifying that you solved the problem and your description of the process.

                          Thanks for all your help - and I am sorted now. A few things (no doubt well known) that threw me, might be useful to others.

                          1) To make Instant web publishing work you will have to configure File Maker Pro and your network router

                          2) The Local URL that Instant Web Publishing suggests you use will only work with computers on your local network (router, router and switches, or several routers - connected with ethernet cables) and computers connected wirelessly to the network.

                          Local Network IP addresses are 90% of the time 192.168.xxx.xxx [192.168.1.1 for router, 192.168.1.2 and up for computers] another octet used is 10.0.1.x [10.0.1.1 for router, 10.0.1.2 and up for computers]  [http://en.wikipedia.org/wiki/Private_network]  [http://en.wikipedia.org/wiki/IP_address]

                          3) To allow a computer connected to the internet in another way to use Instant Web Publishing you have to "punch a hole" in your router's broadband settings. That is, you must go into your router's settings (using a web browser - you will need the router's password details) and configue Port Forwarding [http://portforward.com] to work with the computer that hosts your copy of FMP. 

                          NOTE: - Writing down the IP address of your router, the administration username and password, and model number and taping it to the router is useful.

                          This means locating your hosting computer (the one running FMP) on the network and adding FileMakerPro as you might a game or other application using Port Forwarding. It sounds scary but it isn't too hard. The port to use if you want to give someone access who doesn't have their own copy of FMP is 591.
                          [Ports are reserved for certain processes 80 for html (webpages), 21 for FTP (file transfer), and 591 for Filemaker IWP]

                          Once done, you are nearly set. The ULR will be your IP address with 591 appended (and you append it with : -- a colon, not a / or a .)

                          4) So, if you want a user, connected to the internet on their own computer using a completely different internet connection, to access a file in Internet Web Publishing, you use the IP address with the 591 added. But be careful (this fooled me) the ULR is NOT the IP of your host computer (ie the one running FMP). NOR is it the ULR of your router (ie where you go to change the settings on your broadband). IT IS your actual IP address which can be found using a website like http://whatismyipaddress.com.

                          Finally, remember that if you want to access your files through another computer in your set up which does use your internet connection, the address will be the one that FMP gives you - ie the Local IP Address of your computer with the 591 appended.
                          NOTE: if you take your laptop to the library, you will have to use the Global IP Address to access your IWP database.

                          There is one more issue to be aware of. If your broadband provider only gives you a dynamic IP Address (not a static IP Address), you are going to have to live with monitoring whether your IWP URL is still working - and changing it to the new IP address as necessary.
                          NOTE: there are free services that will avoid this problem - http://www.dmoz.org/Computers/Internet/Protocols/DNS/DNS_Providers/Dynamic_DNS/

                          This is a layman's account so I may have missed things but hope it is helpful. And thank you for everyone who pointed me to this conclusion.

                          Nigel

                          I have edited and added some links - hopefully for more info.

                          • 10. Re: Problem with Instant Web Publishing
                            DgWater

                            thank you for adding the pice about dynamic IP Address problem and potential solutions. That might help me solve a problem since I have a broadband provider who does dhcp. Smile