9 Replies Latest reply on Mar 19, 2012 4:05 AM by Aloha1

    Problems with a dot

    Aloha1

      Title

      Problems with a dot

      Post

      Hi,

       

      I have a field of variable length and it has to be followwed by a dot.

      The problem is that the position of the dot doesn't adapt to the length of the field, but remains at the position in the model.

       

      What may I do to force the dot to be directly after the text of the field preceding it.

      I have choosen the option to adapt to the left, but without success.

       

      Thank You for every hint.

       

      Aloha

       

      (Sorry for my mediocre english)

        • 1. Re: Problems with a dot
          symbister

          Aloha!

          I suggest what you can do is set up a calculation field, calculation result 'text', such that

          new_field = old_field & "*"

          then as data is entered in old_field, new_field becomes "XXXXX*" no matter what length ... is that what you're lookig for?

          • 2. Re: Problems with a dot
            Aloha1

            Hi,

             

            I am astonsihed about that method, but it seems to me that it could resolve my problem. Thanks.

             

            However that's not my only "problem":

             

            When I compose a text consisting of fixed text and fields, I have problems making the result look good and regular.

            I also have the problem to make a grammatically correct junction between fixed text and some fields.

            f.i.: (I'm using the french language and thinking about it it seems to me  that that difficulty doesn't exist in the english language because the french "du", "de la", "de l'" and "des" corresponds to the single english expression "of the"):

             

            my texte: "...à l'occasion "; my field: "anniversaire de mariage [wedding anniversary] de...": ...à l'occasion de l'anniversaire de mariage de ..."

            or

            my texte: "...à l'occasion "; my field: "décès [death] de...: "... à l'occasion du décès de ..."

            or

            my texte: "...à l'occasion "; my field:"Première Communion de ...": "... à l'occasion de la Première Communion de..."

             

            How can one manage that situation?

             

            Regards

             

            Aloha


            • 3. Re: Problems with a dot
              philmodjunk

              You could also use merge text:

              <<FieldnameHere>>.

              and the . will  adjust to be immediately after the last character.

              This method also allows you to insert data from fields into a block of layout text. To handle the "junction" between the layout text and the text in the field would require including that text in the field or in it's own field. I don't know if a calculation can correctly select the correct text for this or if a user fluent in French would need to specify the text.

              • 4. Re: Problems with a dot
                Aloha1

                Hi,

                 

                I have followed Your advice and mixed the text blocks with the fields.

                One question: amid the fields included there are several which need an individual formatting: date and amount (50 -> 50 €).

                How may I format those fields in the formula?

                 

                Regards

                 

                Aloha

                • 5. Re: Problems with a dot
                  symbister

                  Hi Aloha

                  I suggest that rather than trying to format within the formula - too hard! - the formatting should be done on the layout, select the field, then open the Inspector, select the Data tab, then Data Formatting, where you can select a range of options for formatting dates or currencies. However, you will need to have originally defined the date field as type date in order to access the date formatting options, likewise your amount should be type number

                  The currency formatting option also allows for the currency symbol - indeed any text - to be after the amount.

                  • 6. Re: Problems with a dot
                    philmodjunk

                    By all means select the block of text and use data formatting in the inspector if you can, but sometimes you have two fields of the same type that need different format options. Unfortunately, FileMaker will apply the same data formatting to all the fields in the block of merge text and then you'll have to use a calculation field to get the formatting you need.

                    • 7. Re: Problems with a dot
                      Aloha1

                      Hi,

                       

                      Data formatting is not accessible (not active)!

                      • 8. Re: Problems with a dot
                        philmodjunk

                        Make sure that the cursor is not active inside the block of layout text. Make sure the bolck of layout text is selected before you attempt to specify data formatting. If the cursor is not inside the block of text and it's selected, you'll see the small squares that form resize "handles" on each corner of the text block.

                        There must be at least one merge field that is part of that block of layout text.

                        • 9. Re: Problems with a dot
                          Aloha1

                          Hi,

                           

                          Thank You for the answer.

                          Meanwhile I have solved the problem in my own way: I have splitted the date in its components:Day, Month, Year, and to get the month name and not the number I use the CASE function (Case(Month(Date)=1;"January";Month(Date)=2;"February";....) and it seems to work. For the day, in French the first day of the month is "1er", and from the 2nd to the 32th day: the number; that problem I have also solved it by Case(Day(Date)=1;"1er";Day(Date)=2;"2";....).

                          Regards

                           

                          Aloha