AnsweredAssumed Answered

Question mark in field

Question asked by Mark5 on Nov 24, 2009
Latest reply on Nov 24, 2009 by Mark5

Title

Question mark in field

Post

I am trying to divide two fields in a calculation but only get a question mark.  All fields are repeating and they are specified as numbers.  The question mark appears in the first row of the calculation only, the other rows are blank.  I have expanded the field (in case it is too small to display the number) and I have formatted the number with a specific number of decimal digits, but still the same result.  The weird part is that if I multiply, add or subtract the two fields the calculation works.  The question mark only appears with the division.  I don't know if this is relevant but, the file was originally FM version 5 and was recently converted to version 10.  The calculation worked with FM5 but not with FM10.

 

More detail, if needed:  One of the two fields in the calculation contains numbers that are manually input or are imported from another FM file.  The other field is a calculation itself that grabs numbers from a repeating text field using the function "LeftWords" and "GetAsNumber" to get the value and convert it to a number.

Outcomes