1 Reply Latest reply on Aug 21, 2012 9:24 AM by philmodjunk

    Question Mark on All Records in a Table

    DanielLadner

      Title

      Question Mark on All Records in a Table

      Post

      I have a production FileMaker 11 database that suddenly had all of the records in one table show up with "?" question mark characters in every field.  Fortunately, I had a glitch-free backup that I used to get things going again for now, but there is still a week's worth of data in that table that needs to be recovered.

      I've tried the following methods to recover the data so far with no success:

      1) Exporting the records to another file (CSV, Filemaker, XML) - only empty fields are exported.

      2) Saving a Clone of the database, then importing the corrupt records into the clone - no data makes it into the clone.

      3) Saving as a Compacted Copy - no difference.

      4) Disabling Indexes on every column in the table - no difference.

      5) Using FileMaker's Recover feature - The "Scan record data and rebuild fields and tables" option erases all of the "?" records.  None of the other Recover options help.

      6) Loading and converting the FM database inside Filemaker 12 - records still show up with "?" fields.  FM 12's Recovery options had the same useless results as FM 11.

      7) Tried the third-party tools "Steller Phoenix Filemaker Recovery" and "Office Recovery for Filemaker".  Neither tool retrieved any data from the table.

      Does anyone have any suggestions on another approach or method I can use to recover this data?