6 Replies Latest reply on May 6, 2009 10:50 AM by KIDO

    quick question about date formatting

    beckett85_1

      Title

      quick question about date formatting

      Post

      im from australia, land down under and ive searched all over the forum, ive fixed it before but cant remember how, it gives me an error entering a date as dd/mm because you need to enter it as mm/dd, is there a way to change the date format to the diff sort in filemaker settings? i can change the display easily but need to change the way u can enter it

       

      cheers

        • 1. Re: quick question about date formatting
          Jade
            

          Hello,

           

          One setting you might want to check is found in the File Options… in the File menu.  Click the "Text" tab at the top and then click the radio button labelled:

          "Always use current system settings" for Data Entry.

           

          HTH… 

          • 2. Re: quick question about date formatting
            WorkingOnIt
              

            Hi beckett85 and Jade,

             

            I am also in Oz and am having the same problem. Jade, I already had that checkbox checked that you recommended. Also, in the "date format" dialog I have checked "leave date formatted as entered" but this also doesn't fix the *error*. beckett, my temp fix has been to provide dropdown calendars on all date boxes so my Aussie users can just choose the date from the calendar. If anyone has the real fix I'd love to hear about it too!

            • 3. Re: quick question about date formatting
              comment_1
                

              The real fix is:

               

              1. Close your file. 

               

              2. Make sure your computer's short date format is set the way you want it.

               

              3. Open your file and save a copy as clone (no records).

               

              4. Import your data into the clone. 

              • 4. Re: quick question about date formatting
                KIDO
                  

                Hi All

                 

                Trick of the mind again.

                 

                If you use a specific format for all date fields, I would suggest that you change the system settings of your operating system:

                - Control Panel - Regional and Language Options in Windows XP.

                 

                Otherwise, in layout mode  select your date field and then select Menu - Format - Date and and in the Dialog select Custom radio button.

                 

                Then, if you wish the format dd/mm/yyyy select 25 and "/" for the 2 columns first row; 12 and "/" for the 2nd row and 2003 for the 3rd row. You can choose different formats for each date field, the custom formats override the system formats, but if you experience different results, try including "Set Use System Formats [Off]" in your start-up script.

                 

                I hope this sorts you out

                 

                KIDO

                 

                • 5. Re: quick question about date formatting
                  comment_1
                     The selection you make in Format > Date… has absolutely no effect upon the method of entering data into the field.
                  • 6. Re: quick question about date formatting
                    KIDO
                      

                    comment wrote;

                    ..................................................................................................................................................................

                     

                    The selection you make in Format > Date… has absolutely no effect upon the method of entering data into the field. 

                     ..................................................................................................................................................................

                     

                     

                    I know that! Notice that I wrote:

                     

                    .......

                    If you use a specific format for all date fields, I would suggest that you change the system settings of your operating system:

                    - Control Panel - Regional and Language Options in Windows XP.

                    .......