3 Replies Latest reply on Mar 29, 2011 12:34 PM by philmodjunk

    Record missing some data

    robyne

      Title

      Record missing some data

      Post

      filemaker 11.2 & server running on OS 6

      I have record that has missing data (like creation date and notes). If you go to find mode and search for empty fields,  however, none will show up so I am concluding that the data is still there somehow.  My backups seems fine, consistency check seems fine and there have been no reported crashes, errors, power outages.  For the record,  all the data was there upon it's creation and during a follow up access (I know this as I have hard copies plus the backup version).

      Any ideas why this could be happening?

        • 1. Re: Record missing some data
          philmodjunk

          How can you tell that the data is missing?

          Are you examining this data on a layout that refers directly to the table where the data is not showing? Or is the data that's missing from fields defined in a related table? (Such as a notes table.)

          If you click in these apparently empty fields, does the data appear?

          • 2. Re: Record missing some data
            robyne

            I can tell the data is missing because it no longer appears in the fields.  None of the fields are related fields.  in particular, the creation time has "disappeared".  However, the wierd thing about it is that if I do a search for records that have no creation time, this record does not appear.  But if I include it in a range where it ought to be, it pops right up but if I do a sort, it is out of order.  This is also true for the name field.  Name is missing but I can find it.  Please note that is appears to only have happened in one record.  I am assuming that the record is somehow corrupted but even that is unclear to me.  I am not sure at this point if I should delete this record completly and reenter it or if I should leave it alone.

            • 3. Re: Record missing some data
              philmodjunk

              You may have problems with the field indexes that can be corrected by re-indexing the fields:

              1. To rebuild the index of a single field, open Manage | Database | Fields and double click the field
              2. Use either the storage tab or the storage options button to turn off indexing.
              3. Exit Manage | Database, then return and turn indexing back on.

               

              You can also rebuild all your file's indexes by importing all the data into an empty copy (clone) of your file.

              If you have FileMaker 11, you can use Advanced Recovery options to rebuild your file's indexes:

              1. With the file closed, select Recover from the File Menu.
              2. Select "Use advanced Options"
              3. Select only: "Copy File Blocks as-is" and "Rebuild Field Indexes Now".

               

              (And you might want to run a recover on the file to check and see if the file Doesn't have any more serious problems.)