1 2 Previous Next 23 Replies Latest reply on Nov 12, 2009 9:09 AM by printerman

    Record numbers always printing as 1

    printerman

      Title

      Record numbers always printing as 1

      Post

      I'm using Filemaker 10. The problem I'm having is that when I insert @@ to show the record number for my job orders, every record prints as 1 even though in browse mode the numbers are fine. I can print any record but they all prints as 1. Also, (another problem), in preview mode I can only view the first record only . It seems so simple but i can't figure it out! Help!

        • 1. Re: Record numbers always printing as 1
          philmodjunk
            

          What records are in your found set at the time you print it?

           

          @@ inserts the record number--which shows the record's location in the current list of records in you found set. If you have a found set of 1 record at the time you print it, it'll show a 1 everytime. This is also consistant with "in preview mode I can only view the first record only".

           

          Are you printing from a script or by selecting Print from the file menu? If by script, check the script out to see if it might be isolating the current record in a found set of one record.

           

          Show All records

          Omit record

          Show Omitted

           

          Is a common trick for doing this.

          If you have a script that previews the record for you and then pauses for you to print it, that preview script may be doing the same thing.

          • 2. Re: Record numbers always printing as 1
            printerman
               Thanks for your reply! I'm not sure what you mean by "found set"...but I usually am printing the most current record. I'm a bit a of a newbie to Filemaker. I don't use a script to print, I simply go file/print from the menu and print current record. No matter what I try to modify in browse mode, the record number always prints as 1. It's so fustrating when it should be so simple. All I need is the matching record number to print on the sheet. Like I say, I see it correctly in browse mode but not when it gets printed. I'm wondering if it is possible to e-mail this file and troubleshoot it that way? Would that even work?
            • 3. Re: Record numbers always printing as 1
              ninja
                

              Howdy,

               

              I wonder if there's a wording miscue going on here.

               

              What exactly do you mean by "Record Number"?  (I wonder if it's the same thing that WE think it means)

               

              Is it the number assigned by FMP?  If so, it will change when you do a find, or a sort...

              Is it a number that you have assigned to the record?  If so, how did you assign it?

               

              If you got to the current record via find, the record number will have changed due to the find.  If you now go to preview mode, it should remain.  If you print only the current record (specified in your printer dialog), will it not be like a find and only see one record?...and thus have record #1?  Not sure about that one.

               

              If you want each record to have a fixed record number that does not change, you might consider autoentering a record number on record creation.  That won't change due to finds, sorts or prints.

               

              Edit: Another thought...is your field big enough?  If it's trying to show "1258" and the field is too small, it might only show the "1"...increase the text box with you @@ in it and verify.

              • 4. Re: Record numbers always printing as 1
                philmodjunk
                  

                I just did a quickie test and learned something new. :smileysurprised:

                 

                If you print using the current record option, @@ returns a 1. Just as though you have a found set of just one record.

                 

                The simplest workaround: Preview the report. You can click the "book" control in the upper left corner of your screen (in the Tool bar) to flip through pages and determine which page contains the record you want to print. Now select the page or range of pages you want to print and print it using the Records being browsed option.

                 

                There may be a much better way to set this up. Since you are printing just one record, what is the Record Number @@ supposed to indicate to the person reading your report?

                • 5. Re: Record numbers always printing as 1
                  printerman
                     I already tried going to preview and scroll from there, but it won't work. Preview is "stuck" on record number one. I can't scroll using the book to get the next record. In response to Ninja's question: Yes, I am simply using @@ which is same as FMP assigned record number. Find is useless too...also shows 1.
                  • 6. Re: Record numbers always printing as 1
                    philmodjunk
                      

                    This not a "scroll" operation, You click on the pages of the "book" to move from page to page.

                     

                    Keep in mind that a "record number" is ephemeral. Circumstances, such as printing "current record" can change what number represents the record number for the record you choose to print.

                     

                    To repeat my question, but with different wording:  When you look at your record in browse mode and see that it's "Record # 5", what does that 5 mean to you?

                    • 7. Re: Record numbers always printing as 1
                      printerman
                        

                      Right, that's what I meant--clicking page to page.

                       

                      It does not allow me to do that...only the first record shows up in preview mode and I cannot click to the next record in preview mode. In answer to your question, it is the same number corresponding with the record number that Filemaker creates in that box next to the book. The reason I need numbering is that when a job is completed it goes to the accounting dept. If there is a missing number then accounting can ask "where's job order 36?", for example.

                       

                      The current record that I choose to print will print, but the associated number with that record does not...it always prints as the number one. Keep in mind I am placing @@ so that it corresponds with Filemaker generated record number and not creating a field that generates numbers. That method does work but the problem with that is that when you delete a record and go on the the next record the numbering gets screwed up and you have missing numbers.

                      • 8. Re: Record numbers always printing as 1
                        philmodjunk
                          

                        Hmm,

                         

                        You might want to check this bug report:

                         

                        Next Page button sometime shows as inactive when it should be active

                         

                        and see if your settings match what's reported there.

                         

                        In any case, I don't recomend that you use the record number function for this purpose. The same record will print out with different record numbers depending on context. Once such context being printing the current record. I suggest you re-think the use of an auto-entered serial number.

                         

                        There are ways to use scripts to manage your serial number settings to avoid gaps.

                         

                        One method is to script your own record delete so that it updates the serial number after a record or records are deleted. You can use Accounts & Privilege settings to disable deleting records from the Records menu and/or keyboard and then set your delete script to run with full access privileges and put a button for it on your layout. If you have FMP advanced, you can also customize your menu so that delete record runs your script instead of the original delete record command.

                         

                        Another method is to flatly prohibit all record deletes. Instead, you mark all records you want deleted as "void" and clear any fields you need to clear to keep your voided record from affecting any reports. This still leaves you with a placeholder to avoid any gaps in your number series.

                        • 9. Re: Record numbers always printing as 1
                          raybaudi
                            

                          printerman wrote:

                           

                          ...only the first record shows up in preview mode


                          I think that solving that problem will solve the other.

                           

                          Why you can't preview the other records ?

                           

                          Go in layout mode and see where are your fields, in wich part ? The Body, the Header , the Footer ?

                          • 10. Re: Record numbers always printing as 1
                            philmodjunk
                              

                            Raybaudi,

                             

                            THere's a known bug that can keep a user from using the book control to move to subsequent pages while in preview. Click the link in my previous post to read more. It may apply to this situation or not. Whether it does or not, I don't recomend using record number for the purpose described here.

                            • 11. Re: Record numbers always printing as 1
                              raybaudi
                                

                              PhilModJunk wrote:

                               

                              Click the link in my previous post to read more.


                              I did.

                               

                              But that bug gives ONLY the impression of not being able to have other records to see.

                               

                              I suspect that printerman has fields in the wrong layou part.


                              • 12. Re: Record numbers always printing as 1
                                philmodjunk
                                  

                                It's certainly possible that there is a layout issue.

                                 

                                However, the bug describes not being able to advance to the next page in preview mode and this is exactly what are OP describes. The questions to ask to determine if this bug is a factor:

                                 

                                Are you using FMP on a Mac system?

                                If so, have you selected Customize Tool Bar from the view menu and then selected "Use Small Size" to select a smaller size for the tool bar icons?

                                 

                                If yes, then this explains the disabled "book" in preview mode. Reselect the original settings and you should be able to select a page. If not, look at your layout for issues.

                                • 13. Re: Record numbers always printing as 1
                                  printerman
                                     I just checked the Customize Tool Bar and Use Samll Size is NOT selected. I am also suspecting a layout issue as well, but I am not sure what paramaters that would cause the numers not print incorrectly.
                                  • 14. Re: Record numbers always printing as 1
                                    raybaudi
                                      

                                    Please, in layout mode go to see the names of your parts and which of them contains your fields.

                                     

                                    After say that to us.

                                    1 2 Previous Next