1 2 Previous Next 20 Replies Latest reply on Jun 5, 2012 11:14 AM by GuyStevens

    Records not being saved.

    KellyLichtenwaldt

      Title

      Records not being saved.

      Post

      I'm a fairly new Filemaker Pro user. Used it for years, didn't for the last few, now I'm using it again.

      FMP 11.0v4

      MacPro

      2x2.66ghz dual-core Intel Xeon

      5 GB 667 MHz DDR2 FB-DIMM

      OS 10.7.3

      I'm using the simple "invoice template" with no modifications. 

      I've invoiced three clients. I used the "send inoice to email" with sucess.

      Now, the fourth invoice I created was fine. It emailed fine. It saved a PDF copy of it on my desktop fine.

      However, It's not anywhere to be found as a record in Filemaker. It's like I can't save more than 3 records. 

      I even tried making a few fake invoices. closed filemaker, re-opened it  and they were gone as well.

      What can I possibly be doing wrong here?

      Kelly

        • 1. Re: Records not being saved.
          GuyStevens

          Have you done a find?

          Maybe you are not seing all records.

          Does the top of your screen look like this:

          find

          Or like this:

          Find

          If the sphere is green, you should try clicking "Show All"

          I've given myself heartattacks in the past thinking a bunch of records were gone only to find out I was in a found set of records.

          It can't be that filemaker is only storing 3 records. So there has to be something funky going on.

          Are you sure you are opening the correct file? And not a backup?

          • 2. Re: Records not being saved.
            KellyLichtenwaldt

            Yeah. Its simply not saving my invoices. Attached is a screen shot. Did the same thing yesterday. Ivoiced, emailed, then poof. It dissapeared when I opened up Filemaker this morning.

            It is literally like my overnight backup is somehow un-doing everything I've done that day. Only on this application. Not Photoshop, Aperture, Adobe Bridge or any other programs I use on the same drive on the same computer. 

            Thanks for the heads up on the show all. I am hip to that, but I feel like i'm overlooking something exactly like this somehow.

            Kelly.

            • 3. Re: Records not being saved.
              GuyStevens

              If you want I could have a look at your file, if you want you could send me an empty copy.

              Then I could see if I could get more records in there.

              How are you making your backups?

              • 4. Re: Records not being saved.
                KellyLichtenwaldt

                Now, when I am in record detail - Invoices, and hit "view invoice" (shows me what the client gets), the record number changes (see screenshot). Like it knows all my invoices to the clients once existed, but the records are now gone. I'll keep poking at it, but if there is something obvious that I'm missing, feel free to point it out.

                • 5. Re: Records not being saved.
                  GuyStevens

                  That means the serial number does keep counting up.

                  Are you using any scripts where you delete records?

                  • 6. Re: Records not being saved.
                    KellyLichtenwaldt

                    How do I send you a blank copy of my database? I'd be happy to post it up.

                    • 7. Re: Records not being saved.
                      GuyStevens

                      Either upload it somewhere on the internet and post the link here.

                      Or if you have Dropbox (www.dropbox.com) you can just put it in your "Public" folder and "Copy the public link" and post it here.

                      Or you can mail it to me.

                      I'll send you a PM with my email adress.

                      If you want I can put in in my dropbox public folder and share it with people here.

                      • 8. Re: Records not being saved.
                        Sorbsbuster

                        That screenshot was taken in the middle of a script execution.  Were you aware of that?  When it finishes you will see the Show All button at the top will come 'live'.  If you click it (or do Command J) you will see all the records, not just the current found set of 3.  (There were 12 records when you took that screenshot.)

                        • 9. Re: Records not being saved.
                          Sorbsbuster

                          Also, the two screen shots are based on different tables.  The second one is based on Line Items, so you have raised 12 line items belonging to a range of invoices.

                          The first screenshot is from the Invoices Table, and shows (if the screenshots were taken at the same time) that you have 3 invoices.  So what you may be creating are more line items on the same invoices, not more invoices.

                          If you go to the layout in the first screen shot (Record Detail - Invoices) and check you are in browse mode (Cmd B) and then create a new record (Cmd N), does that 3 go up to 4?

                          • 10. Re: Records not being saved.
                            KellyLichtenwaldt

                            I am aware the screen shot was taken in the middle of a script execution. The script is the "email invoice" script. Good to know that number is based on line items. I didn't know that. I can tell you I am making new invoices, not just adding line items to the same invoice. I know that part is working as expected.

                            When the script is finished, it goes back to the invoice count, and the button is live again.

                            Yes. When I'm in browse mode, and hit "new record", the counter goes up to 4. I'm able to enter in information, then email that finished inovice out. I can look at the record detail screen, see everything in it. All is good. Until I close and reopen FMP.

                            I quit filemaker, re-open it and that record is gone. The only vestiage of that invoice left is the PDF that it automatically saves to my desktop during the 'email invoice' script. Like the last step in the script is "delete record" for god knows why. I tried to replicate this by not using the "email invoice" button. Invoices still dissapear at a restart of the software.

                            DaSaint  -  Thanks. I can use those methods, but what I don't know how to do is create the blank database.

                            Related - The same thing happens when I try and add new customers. I add them, they seem to be saved, but when I close and re-open Filemaker the new additions are gone. It is literally like I'm stuck in demo mode, the database is stuck in 'do not save changes mode' or some other simple thing.

                            As for my automated backups:

                            I use Carbon Copy Cloner. Every morning at 4 AM it clones all changes from my main boot drive to a backup boot drive. Same for my media drive. It does an incramental backup, not a full wipe and re-write. I can replicate this not saving issue prior to the backup running though.

                            Frankly, I'm going to blow this database up, and re-enter data into a new DB and see if the problem follows. I don't have a ton of info in here yet, and I have copies of all the PDF's to reference.

                            Here is why I think it's a bug of some type - 

                            The records don't delete every single time I restart FMP. sometimes, at a restart, all the new records are present. All is good. I open up the DB a few hours later and they're gone. Even prior to my Carbon Copy Cloner backups happening.

                            Help is appreciated, but I think I'm starting over from scratch.

                            Kelly. 

                            • 11. Re: Records not being saved.
                              GuyStevens

                              The reason i said to provide us a blank copy is so your data that's in there doesn't get seen by other people.

                              The idea would be to create a copy of your file. To open that copy in Filemaker and to delete the existing records. Like your invoices and your client records.

                              That way we can look at the scripts etc. in your file.

                              And we can try to replicate the problem on your file.

                              • 12. Re: Records not being saved.
                                Sorbsbuster

                                "The records don't delete every single time I restart FMP. sometimes, at a restart, all the new records are present. All is good. I open up the DB a few hours later and they're gone."

                                I believe you are opening a copy of the file.

                                • 13. Re: Records not being saved.
                                  KellyLichtenwaldt

                                  Well, I think I've solved it. File under new user error. Check the screen shot.

                                  Every time I open FMP, this window opens up. I select the most recent database at the top of the list. Thats my problem. The window doesn't show the full database name and path in this open screen. I have been opening an old database, with an identical name, from my backup boot drive (My Documents folder). I poked around ouside of FMP and found 4 databases labled "Tekbench Invoice<space-some other text>". Two databases with the same name (Tekbench Invoice) in two different spots, one appended with "-recovered" and one that I had made with 'Test' in the title.

                                  I think FMP has been just opening the DB from the backup drive. The DB I SHOULD be opening hasn't changed in like 3 weeks. I just keep opening the old one from the backup, make changes, then the Backup wipes them out and replaces it with the DB from my main boot drive (with 3 invoices in it). Somewhere along the way, I opened the correct DB, made some changes to customers and those stuck around.

                                  Would be nice if the Quick Start screen showed where the files are located. Especially if you drag the window out wide. As it is now, I can't lable my DB's something like "Tekbench Invoice 2012" and see the DB name in that 'recent files' list. It just shows "Tekbench Invoice .../Documents". This is fine, but the real path is "Tekbench Invoice/New Boot A/My Documents" and that is very different than "Tekbench Invoice/BACKUPBOOTA/My Documents" and super different than "Tekbench Invoice 2011/New Boot A/My Documents". Currently these all read as "Tekbench Invoice .../Documents". This, to me, seems confusing. Especially since i use the Quick Start pages for exactly that. Starting quickly. Like when a clent is ringing my phone. I can launch FMP, and click their DB before I pick up the phone without resorting to using 'Finder' on my mac.

                                  I've used the 'manage my favorites' option and put the correct DB there. Where you can actually see the entire file name. I think this solves it for me. I'll also be un-checking the "show this dialog at startup" button and coming up with some shortcut scenario. If you're going to show that dialog. for god sake can't you show the full database file name in the 'recent files' area? Sure. If you hover over it, it pops up eventually. Not Quickly. But this seems like a really lame 'Quick Start' menu 'feature'. I have a widescreen monitor, If I drag the box out to the right, expand the the "recent files" area to show the Full name of the DB. Not a big deal except my naming of DB's tends to get long. Every client ALSO gets a small DB attached to them to record all the work I do for them. In my case, this leads to a long list of DB's, each starting with "Tekbench<some other stuff>". I guess I'll just use the favorites, or skip the "Quick Start" page all together.

                                  Frustrating.

                                  • 14. Re: Records not being saved.
                                    GuyStevens

                                    Are you by any chance sharing this file using Dropbox?

                                    And opening it from different computers?

                                    Doing this there is always a chance your file doesn't get uploaded properly. Or it could get opened on different computers at the same time.

                                    If that's the case you are creating "conflicted copies"

                                    1 2 Previous Next