6 Replies Latest reply on Apr 7, 2010 6:44 AM by jbkfrench

    records numbered sequentially

    jbkfrench

      Title

      records numbered sequentially

      Post

      I'm working with  a database that was created by someone that is long gone.  There is a field that assigns a sequential registration number.  WE would like to be able to either reset this number to begin at 1 for a new database or change the field so that we can enter a number on our own.  If we try and enter a number over what is assigned, the whole record does not show in the report screen - but we can change the number again on the report screen and the record will then show.

       

      I'm a Filemaker newbie and not sure where to look for this type of formatting.  Double clicking on the field in the layout screen brings up an inspector - but nothing there seems to indicate a sequential number field. 

       

      Any help here is greatly appreciated.

        • 1. Re: records numbered sequentially
          philmodjunk

          This is most likely a number field with an auto-entered serial number.

          Open Manage | Database | Fields

          Find the field's definition and double click it.

          Click the auto-enter tab.

          Now you have a dialog where you can change what will be entered in the next new record to be created.

           

          However,

          I strongly advise carefully examining the structure of your database and how this field is used in relationships. This field might be used as a primary key for uniquely identifying records. Altering this value, as you've already discovered in one part of the database, may affect how data in table links to related data in other tables.

           

          Be cautious and make a back up before you change anything.

          • 2. Re: records numbered sequentially
            jbkfrench

            Thanks for your prompt reply.

             

            I was heading in that direction but database was greyed out and I was unable to get to that  - what do I need to make sure is closed or not active to be able to see that?

             

             

            • 3. Re: records numbered sequentially
              philmodjunk

              What version of filemaker are you using?

               

              If this is a hosted file, some versions won't allow access to this section until you take it down off the server--that's a very good idea here anyway since you don't want the changes you are making to impact actual use of the database until you are sure your changes will not cause problems for the database.

               

              Also: You need to have the Database open with a full access password and there shouldn't be any paused scripts. (You'll see continue and cancel buttons in the status area if a script is paused.)

               

              If you were not asked for a password when you opened the file, it is still possible that a password was used to open the file for you when you opened the file. Open the file while holding down the shift key, Windows, or the option key, mac, and see if you are asked for a password.

              • 4. Re: records numbered sequentially
                jbkfrench

                I was finally able to give this a try - using a trial of version 11

                 

                still not able to get to Manage>Database

                 

                used password to enter file - but for some reason all that is "active" under Manage is Value Lists, Layout and Scripts

                • 5. Re: records numbered sequentially
                  philmodjunk

                  It appears your password is not a full access password. Restrictions on your password's privilege set are likely preventing you from accessing Manage | Database. You should contact the last person to make development changes to the database to get this password.

                  • 6. Re: records numbered sequentially
                    jbkfrench

                    Once we got the correct password it worked.  Thanks for your help.