5 Replies Latest reply on Feb 19, 2013 11:30 AM by BarretBowman

    Relationship Issues

    BarretBowman

      Title

      Relationship Issues

      Post

       Hello, I am trying to connect one table to another via relationship. I have done so with other tables thus far but for some reason I cannot get this one to work the way I'd like it to. I have a table of records showing clips in a final cut editing sequence that are connected to another table with the video files. I created another table for markers that include timecode and information that I'd like to connect as well. I created the table, gave it an ID, imported the information, created a portal on the clips table, and created a relationship between the two "name" fields that have the same name. I'd like to be able to look at my clip record and have all the necessary marker information pop up. I feel like I am missing a step or doing something wrong.

      FMP12__FCP7_Screenshot_5.jpg

        • 1. Re: Relationship Issues
          BarretBowman
           Here are the relationships.
          • 2. Re: Relationship Issues
            philmodjunk
                 

                      I created the table, gave it an ID, imported the information, created a portal on the clips table, and created a relationship between the two "name" fields that have the same name.

                 I don't see a relationship that matches by two name fields. Unless your import imports data into ClipIDFK that matches to the value in ID of the correct related record in clips, your portal will not show any records as they have not been correctly linked to records in the Clips table.

            • 3. Re: Relationship Issues
              BarretBowman
               My apologies, I had not adjusted my relationships before posting that. So if I do it like so, it won't work? All the related name fields match and I am not seeing the info for the markers come up.
              • 4. Re: Relationship Issues
                philmodjunk

                     Double check to be sure that Title and Name are both text fields and that they have exactly the same text when they are supposed to match.

                     One way to test that is to go to your Clips layout and copy the contents of Title to the clipboard.

                     Then switch to the Markers layout, enter find mode and paste the copied text into the name field.

                     Perform the find to see if any records are found. Check the data in name field for these records and make sure that they exaclty match the Clips record.

                • 5. Re: Relationship Issues
                  BarretBowman
                   Thanks! Had to add- Name&".mov" for it to work