7 Replies Latest reply on Dec 27, 2013 7:03 AM by philmodjunk

    Relationships no longer working...

    LouisBud

      Title

      Relationships no longer working...

      Post

           I work with FM Pro 10 on a Mac with Mountain Lion. Up until now, when I've typed in one section in a database, the rest has auto-filled, as I set it up to do. All of a sudden that doesn't seem to be happening. Anyone else have issues with this?? Thanks for any help!

        • 1. Re: Relationships no longer working...
          philmodjunk

               Has anything changed since this stopped working?

               What method of "auto-fill" did you have set up?

          • 2. Re: Relationships no longer working...
            LouisBud

                 there seem to be compatibility issues with Filemaker 10 Pro in 10.8.5. For example FM will no longer print multiple records in lists, which leads me to think this is the problem.  As for auto fill it is set to: “Auto-complete using previously entered values”

            • 3. Re: Relationships no longer working...
              philmodjunk

                   Does that mean that you upgraded your OS and this then broke?

                   Here's a link for a 30 day free trial copy of FileMaker 11 that should still work: http://info.filemaker.com/Us_en_FileMaker_Pro_11_Trial.html

                   You can install this trial copy and use it to open and test your file to see if the upgraded copy resolves the issue. If so, that will confirm your hypothesis about why this is failing to work.

                   But also be aware that damage to your file or the loss of indexing on the field could also "break" this feature.

              • 4. Re: Relationships no longer working...
                LouisBud

                     Hi Phil. thanks for that. FMpro 11 solves the printing records issue (including allowing the printing of one record from a list of records through the print interface) but not the interrelationship issue. I'm thinking I might need to rebuild this with an intermediary table between the offending, unresponsive table and the main table.  Any advice if I should download/upgrade to FMpro 13?

                • 5. Re: Relationships no longer working...
                  philmodjunk

                       I don't think that add an intermediary table will solve anything.

                       Try this instead:  Recover a copy of your file and then test the recovered copy to see if it works as expected with regards to relationships. Test it even if the recover does not report finding any problems.

                       The recovered copy will have totally rebuilt indexes and that might resolve this issue. If the recovered copy has working relationships, you can make a new recovered copy where the only change to the file is the rebuilt indexes if you select only the options: "Copy File Blocks As Is" and "Rebuild Field Indexes Now".

                  • 6. Re: Relationships no longer working...
                    LouisBud

                         thanks Phil.

                         I've tried this in FM10, 11 and 13 all without luck. With FM 10 and FM11 it took a few moments to rebuild index files, etc, but I'm still left with the same issue.

                         As it stands now, in FM10, 11 and 13 when I'm in the main table and try to make changes to the info in the secondary table (:) it seems to add new records in the secondary table rather than pulling the information from the record in the secondary table for that field (and the other fields of that records in the secondary table). Also, even if a record is deleted in the secondary table it seems to reappear in the main table and re-create a record in the secondary table.

                         I've also created an entirely new secondary table, which when data is added in the primary table creates new records in the secondary table of with the same name (but not with the related information included with the original record in the secondary table) 

                         As well, un-checking "Allow creation of records in this table via this relationship" makes it impossible to add data to the (:) secondary data fields via the main table. However,  checking or un-checking "Delete related records in this table when a record is deleted in the other table" seems to have little bearing on whether or not information disappears from the fields in the secondary data fields. Sometimes they seem to be deleted, but then it also seems to delete all the information in the record in the secondary table along with all instances in the main table. I'm totally confused.

                          

                          

                    • 7. Re: Relationships no longer working...
                      philmodjunk

                           I've tried this in FM10, 11 and 13 all without luck.

                           That would strongly suggest that the FileMaker version is not the issue here.

                           I recommend examining the details of your relationship and layout design for possible issues. If you wish to pursue this further here, I suggest starting with a detailed description of the relationships and their match fields, then describe the layout and any scripts involved so that we can get an idea as to where to investigate more closely for how/why this is happening.