4 Replies Latest reply on Sep 11, 2013 12:53 PM by philmodjunk

    Replace Field Contents bug

    JohnCalvelli

      Title

      Replace Field Contents bug

      Post

           In Filemaker 12.0v4

           I have some search results. I paste some text into a field, and choose the option to replace field with the text. It doesn't work! 

           I am doing the same thing I have done for the last 10 years, and it has always worked. The only difference is that it is the new version. However, earlier today it worked fine.

           What could be wrong?

        • 1. Re: Replace Field Contents bug
          philmodjunk

               Works fine for me in 12.0v4 and I use it frequently.

               I suggest that you describe in more detail exactly how you used it and exactly how it failed. (BTW, bug reports should be posted in Report an Issue, but I suspect that this one is not due to a bug.)

          • 2. Re: Replace Field Contents bug
            JohnCalvelli

                 Ok, I'll try to give as much detail as I can. Restarting didn't help.

                 My FM12 file uses 2 databases: one, _Images, which is used for importing folders of images; and two, _Data, a db with two tables, designdata and corefields. In Manage Database for "_Images" The relationships between the tables are working properly in all other respects.

                 I put my cursor in one of the fields in designdata, called Image Notes. I go to the menu item Records>Replace Field Contents. By default, the dialog box is selected to "Replace with: "xwz words...". I click "Replace" then browse to see the other 2 records in the found set do not have the text replaced.

                 That is the same procedure I have always used successfully. I've also tried pasting in new text as well as selecting all the text, and it also doesn't work.

                 I work on a MacBook Pro 2.4 gh with OS 10.8.4

                  

            • 3. Re: Replace Field Contents bug
              JohnCalvelli

                   Small edit: in the second line, the text "Manage Database for "_Images" was meant to be deleted. Ignore it.

              • 4. Re: Replace Field Contents bug
                philmodjunk

                     And on what table is the layout where you tried this based? designdata or a related table?

                     If you create a small test file with a text field and a few records in one table, does replace field contents work in it?

                     If so, try running a recover on your file and then test out Replace Field Contents on the recovered copy. Does it work?

                     If that works, you may want to replace your file with a backup copy or to try rebuilding the index on the Image Notes field.