10 Replies Latest reply on Jun 16, 2009 8:43 AM by WF7A

    Resetting FM ProAdvanced menus to their defaults?

    WF7A

      Title

      Resetting FM ProAdvanced menus to their defaults?

      Post

      Hi, everybody--don't get up.

       

      I somehow made the Insert--Sound and Insert--Quicktime menu items disappear from the standard menu set, so how do I reset FM's standard menu set back to its defaults?

        • 1. Re: Resetting FM ProAdvanced menus to their defaults?
          mrvodka
             I dont think it is possible to modify the [Standard FileMaker Menus] menu set.
          • 2. Re: Resetting FM ProAdvanced menus to their defaults?
            TSGal

            wf7a:

             

            Thank you for your post.

             

            The answer by "mr_vodka" is correct (Thank you!).  To change this back to the default, pull down the Tools menu and select "Custom Menus -> [Standard FileMaker Menus] ".  You probably inadvertently set up a custom menu entitled "Custom Menu Set 1".

             

            TSGal

            FileMaker, Inc. 

            • 3. Re: Resetting FM ProAdvanced menus to their defaults?
              WF7A
                

              Thanks for the help, both of you. I did as instructed but still have the problem of having the Insert Sound menu choice 'grayed out' even though the other insert-type functions work when my cursor is parked in a container field. Is there something else I'm missing here, or...?

               

              ...and yes, I'm logging into the solution with full Admin privileges.

              • 4. Re: Resetting FM ProAdvanced menus to their defaults?
                TSGal

                wf7a:

                 

                Thank you for the additional information.

                 

                First, create a new database file with one table and one field: a container field.  Go into Browse Mode, put your cursor in the Container field, pull down the Insert menu and see if "Sound..." is available.  If not, then reinstall FileMaker Pro.  If it is, then there is something about your original file that FileMaker Pro does not like.  Close the file, pull down the File menu, select "Recover...", select the suspect database file and recover.  When finished, open the recovered database file and see if Insert -> Sound is available.

                 

                TSGal

                FileMaker, Inc. 

                • 5. Re: Resetting FM ProAdvanced menus to their defaults?
                  WF7A
                    

                  Rats—I did as instructed but with no improvement, so it looks like Reinstall City.

                   

                  UPDATE

                   

                  I reinstalled FM Pro Advanced 10.0.v2—same problem: no access to Insert--Sound.  I'm not sure if this has any bearing or not, but Sound Recorder works fine (in MS-Vista) and I have a 64-bit machine.

                  • 6. Re: Resetting FM ProAdvanced menus to their defaults?
                    TSGal

                    wf7a:

                     

                    I'm not sure what is the cause.  I have just finished testing with another Support Technician, and we could not duplicate the problem.

                     

                    1. Tried this on a Macintosh using OS X 10.5.7

                    2. Tried this on a Macintosh using OS X 10.5.6

                    3. Tried this on a Windows machine using XP sp3

                    4. Tried this on Windows under Boot Camp.

                    5. Hosted the file on a Mac and accessed from another Mac

                    6. Hosted the file on a Mac and accessed from Windows XP sp3

                    7. Hosted the file with FileMaker Server 9 and accessed from both Mac and Windows XP sp3

                     

                    In all cases, "Insert Sound..." was available either from the Insert menu or from right-clicking/control-clicking.  We even turned off the Sound in all computers.

                     

                    Do you possibly have any kind of sound plug-in?  Our only conclusion is that either FileMaker Pro is corrupt (which I doubt) or something has been added that interferes with the Sound settings.

                     

                    If you have access to another machine, install FileMaker Pro on that machine and see if you can duplicate the problem. 

                     

                    If you have any additional information, or if you discover the cause, please let me know.

                     

                    TSGal

                    FileMaker, Inc. 

                    • 7. Re: Resetting FM ProAdvanced menus to their defaults?
                      WF7A
                        

                      There's nothing like a challenge, is there? Here's some more information:

                       

                      The FM Pro Adv v10 file I'm using is the one we FBA folk were allowed to download a few months ago when v10 was released. I just rebooted it and started it in Safe Mode—it didn't solve the problem. I then installed the same FMPA file onto my XP laptop: Insert Sound works there, so at least I've localized it my Vista Home Premium AMD Phenom 64-bit processor machine. (It has lots of RAM.)

                       

                      If it's any help, your team can connect to my machine via TeamViewer (or a similar program) to remote access it and take it for a test drive to see if they can spot anything obvious. I work from home so if you'll e-mail me a time and date that'd be convenient for your engineer(s) to connect to my machine, I'm available at his or her convenience. (I live in the Pacific time zone.)

                       

                      Ciao!

                      Rich

                      • 8. Re: Resetting FM ProAdvanced menus to their defaults?
                        TSGal

                        wf7a:

                         

                        Unfortunately, I do not have access to Vista Home Premium, so let me make some inquiries and test it first.

                         

                        TSGal

                        FileMaker, Inc. 

                        • 9. Re: Resetting FM ProAdvanced menus to their defaults?
                          TSGal

                          wf7a:

                           

                          I was able to use a Vista Business machine in the Testing area (no luck with Vista Home Premium).

                           

                          I started FileMaker Pro 10 Advanced, created a simple file with one Container field, accessed the first record, pulled down the Insert menu and all four options (Picture, QuickTime, Sound and File) were all available to me.  I'm not sure what else to try at this point.

                           

                          TSGal

                          FileMaker, Inc. 

                          • 10. Re: Resetting FM ProAdvanced menus to their defaults?
                            WF7A
                              

                            Thanks, TSG. Here's the latest development...if you want to call it that: On a lark I created a runtime and the Insert--Sound works there. I then went back to the master file and lo and behold, Insert--Sound works there, too! So, I don't know if creating the runtime did the trick or not, but (for now, anyway) I'm good to go.

                             

                            Thanks for all your help--I really appreciate it!