1 Reply Latest reply on Feb 5, 2011 2:04 PM by Sorbsbuster

    Script not working from button

    Kaps_1

      Title

      Script not working from button

      Post

      I am having a wierd problem on my scripts within a particular Filemaker database. If I run the script from "scripts" on the main toolbar then everything is fine. When I run the script from a button the script works but does not give the correct result. See attached image. thanks

      regards

      Kaps

      script.JPG

        • 1. Re: Script not working from button
          Sorbsbuster

          I suspect that the problem lies with the exact location of the button.  Maybe the script (or rather 'you...'!) is being fooled by which record is active when you click the button.  To test that I'd suggest:

          - click in the record you want to view.  Click the script from the Script Menu and confirm it works the way you expect.

          - go back to that record view.  Click the button and see if it works.  Go back to the original view and see if the active record is absolutely definitely the record that you thought you started on.

          Just a thought.