AnsweredAssumed Answered

Script on Server unable to "Import Records"

Question asked by CatherineTyers on Jun 15, 2015
Latest reply on Sep 5, 2015 by wimdecorte

Title

Script on Server unable to "Import Records"

Post

I am trying to export records from FM to SQL using a scheduled script running on the FM server. My script works fine when run manually but fails with error 100 ( cannot find file ) when run by the scheduler at the “import records” stage.

I have spent many hours researching this on this forum and the internet and there is a lot of conflicting information. To clarify my exact situation, I am using FM 13 and SQL Server 2008 R2.  I have a single FM file residing on the server containing the source table, the target ESS shadow table and the script.

To ensure it wasn’t a problem with the external ESS table/DSN, I tried copying between native FM tables within the same FM file.  The Import script step still “cannot find file” when run under Schedule, so it doesn’t appear to be a problem with the external source table, more a problem of importing within a single FM file using the scheduler.

FM help indicates ”Importing/exporting directly to and from another FM Pro file is not supported via a FM Server scheduled script”, however, this is all done on the same single FM file.  Does this imply we cannot import to and from the same FM Pro file either?

I have tried all possible paths for describing the FM file within the Import Records script step, nothing works.

Is there any other way of copying a set of records from one table to another within a single FM file on the Scheduler?  Copy records and paste doesn’t work either, not least because I only want a small subset of the source table fields.  I would prefer not to have to export to an intermediate file and reimport.  I would also prefer not to have to create a “robot” file to run the script from FM Pro on the server as we have a limited number of licences available.

Can anyone please shed some light on this?

Thanks in advance, Cathy

Outcomes