9 Replies Latest reply on Oct 13, 2009 12:37 PM by philmodjunk

    Script Step Go to Field not working when worked just fine until today

    trkravtin

      Title

      Script Step Go to Field not working when worked just fine until today

      Post

      I have four fields that are attached to scripts activated by script triggers upon Object Save. These worked JUST FINE until today, when the final script step to return the original field is not followed. I have used the Script Debugger, and on the final script step the cursor is in the field but upon exiting the script the cursor jumps to some other field, two or three tabs steps forward or away from the appropriate one. ?? Why?? Why, today, and not all the other days?? I've restarted FM, I've restarted my computer, but no resolution. I've tried inserting the Go to Object command, and naming those fields as objects, I've tried running another script that essentially is a Go to Field script that does work independent of this situation, and NONE of those solutions resolves the issue. This was originally a zippscript plug-in script that I converted to the script trigger function in v 10.

       

      I have Windows XP SP 2, FM v 10.0v3. Such a simple command cannot be followed. Any help would be appreciated.  

       

      Here is the script:

       

       

      Search ISBN13

      Set Error Capture [ On ]

      Enter Find Mode [ ]

      Set Field [ Book List::ISBN 13; Book List::SearchISBN13 ]

      Perform Find [ ]

      Go to Field [ Book List::SearchISBN13 ]

      Select All