AnsweredAssumed Answered

Search by range date - get(currentdate) in wrong format

Question asked by paolobkk on May 29, 2010
Latest reply on May 29, 2010 by paolobkk

Title

Search by range date - get(currentdate) in wrong format

Post

I'm making up a database with daily activities and I summarize them in a list view sorted by Date.

So I've made a script to "filter" all the list to show me the last 5 days (this script will be applied to a button).

 

This is what I got so far:

 

Enter Find Mode []

Go to Object [Object Name: "SearchDate"]  - (I've named the date field like that because I have 2 around the layout)

Insert Calculated Result [Select;(Get ( CurrentDate ) - 5 ) & "..." &  (Get ( CurrentDate ))]

Perform Find []

 

Everything looks good, I guess, but the script is getting the 2 dates in US format (mm/dd/yyyy) instead of the default (dd/mm/yyyy) and it stops with a message saying that the search criteria must be like dd/mm/yyyy. and it doesn't perform the find request.

 

I'v checked the format on that date field and I also tried to set it as US format, but I still get the same error message.

 

...any clue?  :-/

 

Thanks!  :)

Outcomes