2 Replies Latest reply on Mar 24, 2011 9:08 AM by PatrickDekeyser

    Search function

    PatrickDekeyser

      Title

      Search function

      Post

      Hi there. Can't use my search function properly. e.g. when searching my invoices on quarter number (I enter 09/01) I only get one invoices as result. There should be many more. The field is a textfield and I enter the digits the same way they were created (autofill) when the record (= invoice) was created. This is weird. Never occured before ... Can someone explain the reason ?

        • 1. Re: Search function
          philmodjunk

          I'd make sure that the field is really a text field first. If it's of type number, it might look OK on your layout, but it will affect searches and sorts.

          If you show all records and sort them by this field, do you see all the records with the same data (such as 09/01) grouped correctly and in the order you would expect?

          Sometimes, finds not working as expected indicate issues with the index of the field.

          To rebuild the index of a single field:

          1. Open Manage | Database | Fields and double click the field
          2. Use either the storage tab or the storage options button to turn off indexing.
          3. Exit Manage | Database, then return and turn indexing back on.

           

          You can also rebuild all your file's indexes by importing all the data into an empty copy (clone) of your file.

          If you have FileMaker 11, you can use Advanced Recovery options to rebuild your file's indexes:

          1. With the file closed, select Recover from the File Menu.
          2. Select "Use advanced Options"
          3. Select only: "Copy File Blocks as-is" and "Rebuild Field Indexes Now".
          4. This is one case where it is OK to put the recovered file back into regular use

          • 2. Re: Search function
            PatrickDekeyser

            Fixed !

            Turned indexing off ...

            Thanks PhilModjunk.